0
virtualbox 
   WARNING: The character device /dev/vboxdrv does not exist.
         Please install the virtualbox-dkms package and the appropriate
         headers, most likely linux-headers-generic.

         You will not be able to start VMs until this problem is fixed.

Could someone help me with this ? I can't see /dev/vboxdrv on my own machine. What am I doing wrong ? I am using ubuntu 16.04 and installed already 100 times virtualbox-dkms and linux-headers-generic. Does anyone have anything else to add to this, because everything else that I have tried doesn't work. I have found solutions in here and on github, but nothing works.

If you need anything , any logs just let me know where should I look at ?

6
  • How did you install VBox? What's your kernel version? – fkraiem Nov 21 '17 at 12:36
  • Did u install virtual box from apt? If yes, remove the apt version and try the latest version from Oracle site. – Legolas Nov 21 '17 at 12:46
  • sudo apt-get install virtualbox. Kernel version is 4.10.0-40-generic ? Have I done something wrong ? – FortuneSoldier Nov 21 '17 at 12:52
  • How can I add the user that uses virtualbox to the root ? Maybe this could be the problem ? – FortuneSoldier Nov 21 '17 at 13:08
  • do this also sudo apt-get install virtualbox-dkms linux-headers-generic – Arpit Agarwal Nov 21 '17 at 13:32
0

It sounds like you need to turn off secure boot, or sign the virtual box modules to allow them to run under secure boot. (Turning it off is a lot easier).

See this article for details: https://stegard.net/2016/10/virtualbox-secure-boot-ubuntu-fail/

2
  • It doesn't work for me at all, not like this guy is suggesting. -- "Ubuntu does not sign the third party vbox* kernel modules, but rather gives the user the option to disable Secure Boot upon installation of the virtualbox package. I could do that, but then I would see an annoying “Booting in insecure mode” message every time the machine starts, and also the dual boot Windows 10 installation I have would not function." – FortuneSoldier Nov 21 '17 at 14:58
  • If you want virtual box to work, you will either have to turn off secure boot, or sign the modules. You get to pick one of those choices, or not use virtual box. I suggest you try turning off secure boot - that's easy enough to do, and it's easily reversible if you don't like it. – Organic Marble Nov 21 '17 at 16:05

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.