3

My system specs :

  • Intel i7-8700k (Coffe-lake)
  • Mother board : ROG(Maximus X Hero)
  • OS :Ubuntu-Gnome 16.04

I booted my new PC with Ubutnu-Gnome 16.04, after installation the screen resolution is 1024x768(4:3), and screen is shown Unknown Display. I haven't installed anything on my new OS. My Monitor-CPU connecting Cable is an DP (Pin Cable).

I have tried with "Force create new resolution":

  1. cvt 1366 768 60
  2. xrandr --newmode "< >"

Then an error occurs:

xrandr : Failed to get size of gamma for output default

I want perfect resolution to be fit for my desktop screen.

Can Anyone help me on this problem?

3

Same here...

CPU: Intel i3-8350k (Coffee-lake) Mobo: MSI z370 Gaming M5 OS: Ubuntu 17.10

EDIT

Based on info in this article I've found answer.

You need to add "i915.alpha_support=1" booting parameter to GRUB (Info from here) :

  1. Log in to the system and start a terminal window (Applications->Accessories->Terminal).

  2. In the terminal window at the $ prompt, enter the command: sudo gedit /etc/default/grub

  3. Enter your password when prompted by [sudo]. (If the file /etc/default/grub appears to be empty or does not exist, see the instructions for earlier releases above).

  4. In the editor window, use the arrow keys to move the cursor to the line beginning with "GRUB_CMDLINE_LINUX_DEFAULT" then edit that line, adding your parameter(s) to the text inside the double-quotes after the words "quiet splash". (Be sure to add a SPACE after "splash" before adding your new parameter.)

it should look like this "quiet splash i915.alpha_support=1"

  1. Click the Save button, then close the editor window.

  2. In the terminal window at the $ prompt, enter the command: sudo update-grub.

  3. Restart the system.

I hope it will work for You ;)

  • This did not work for me. – user2205916 Jul 23 '18 at 3:08
  • Can you give a little more context? what happens when you try to follow the steps? what kind of hardaware/os combination you have? – marekbrze Jul 24 '18 at 18:57

Your Answer

By clicking "Post Your Answer", you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.