When using 'Dhivehi' as a keyboard input source, unicode character U07AE does not work when typing on LibreOffice or Gedit.

The character is o on the keyboard. When this key is pressed nothing happens.

All the other keys (characters) work fine except for the one that should be given by pressing o. Even Shift+o Works. I also tried exchanging the mapping of the unicode to another key. Even with that, the unicode character did not work.

I have tried changing xkb/symbol mapping to a different key. But that didn't help.

With xev tool, the Unicode symbol is detected in the Terminal. But it does not work when tried elsewhere.

I can insert the character by typing the Unicode, like Ctrl+Shift+ U07AE. But to do this, I have to change language to English.

This issue came up on Ubuntu 17.10; in 16.04 it works as it should.

  • How do you want to enter it? – Zanna Nov 21 '17 at 12:42
  • Using Libre or edit. – 8fan Nov 22 '17 at 4:04
  • What keys would you like to use to type it in? – user689314 Nov 22 '17 at 5:15
  • @Yamboy1 As 8fan wrote, "The Character is 'o' of the Keyboard", which means they should be able to type it by pressing the O key on their English keyboard. – wjandrea Nov 22 '17 at 5:54
  • @wjandrea: U+07AE is called THAANA OBOFILI. It is a non-spacing mark used in Thaana, a script used for writing the Maldivian language. It has nothing to do with U+004F LATIN LETTER O. – AlexP Nov 22 '17 at 7:34

just for the record, this is fixed by

sudo apt install ibus-m17n

reboot and you would get option to add "Divehi" phoenatic keyboard under regional and language settings.

works in ubuntu 19.04

| improve this answer | |
  • I didn't see a "Divehi" keyboard available to install, but after changing "Keyboard input method system" to "XIM" it's working. – andho Jul 21 '19 at 17:30

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.