2

I'm using Ubuntu 16.04 with LXDE desktop:

Desktop

I'm trying to change the language to German, but I'm not sure how.

Any advice for me?

11

From command line you can try this:

sudo apt-get install language-pack-de language-pack-gnome-de
sudo apt-get install $(check-language-support)
sudo update-locale LANG=de_DE.UTF-8

Then relogin or reboot.

Edit:

It seems from your error message that the English locale has not been created. So run this:

sudo locale-gen en_US.UTF-8

Then I'd recommend an extended update-locale command:

sudo update-locale LANG=de_DE.UTF-8 LANGUAGE= LC_MESSAGES= LC_COLLATE= LC_CTYPE=

Edit II:

To work around the weird settings of environment variables in /etc/lxdm/Xsession, try to open ~/.profile for editing and add this line to the bottom of it:

unset GREETER_LANGUAGE
| improve this answer | |
  • Comments are not for extended discussion; this conversation has been moved to chat. – terdon Nov 22 '17 at 16:01
  • language-pack-gnome-de is just for desktop tho. – scones Jun 22 '18 at 13:14
3

There is no need for terminal to do this, open the 'System Settings' (This is for Unity desktop, for LXDE it is called 'Preferences') application which opens the following window:

enter image description here

Then click on 'Language Support' and you get another window opening and maybe as well get a reminder that the language support is not installed completely.

If that happens click on install which will then prompt you for your password and installs the missing language bits. You will end up in this following window where you can click on 'Install/Remove Languages' button and choose German.

enter image description here enter image description here

Click on 'Apply' to install German for the system. Afterwards click on 'Deutsch (Deutschland)' and move it up in the list to the top. Then click on 'Deutsch (Deutschland)' followed by 'Apply System-Wide'. you will then be prompted for your password again to make it happen.

enter image description here

All then is left before rebooting to set the 'Reginal Formats' to German too and as well 'Apply System-Wide'. To make this change happen you need to reboot.

After this you will get greeted by the following window on your first log in where you can choose to keep the old folder names in your home folder or to actualize them to German as well.

enter image description here

Both options will work, and its up to you to decide what you want there.

| improve this answer | |
1

Finally, I found the answer. I have to follow the steps below.

sudo apt-get install language-pack-de language-pack-gnome-de
sudo apt-get install $(check-language-support)
sudo update-locale LANG=de_DE.UTF-8

Then mark off the comment in /etc/lxdm/Xsession:

# override ~/.profile if language was set on the greeter
if [ -n "$GREETER_LANGUAGE" ]; then
    language_list=${GREETER_LANGUAGE%.*}${GREETER_LANGUAGE#*.UTF-8}:en
    export LANGUAGE="$language_list"
    export LC_MESSAGES="$GREETER_LANGUAGE"
    export LC_CTYPE="$GREETER_LANGUAGE"
    export LC_COLLATE="$GREETER_LANGUAGE"
fi    

Afterwards your system will change to German.

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.