0

I'm on Ubuntu 16.04, Chrome Version 62.0.3202.94 (Official Build) (64-bit), Thunderbird 52.4.0 (64-bit).

I'm having a problem with Chrome that only happens when I click on a link within Thunderbird. If the browser is already started up, everything works fine. If the browser is not already running, it appears that Chrome is opening - the Chrome icon lights up on the launcher - but the page never shows up. This is what I've tested so far:

  • Disabled all plugins, extensions, etc. in both Thunderbird and Chrome.
  • Links open fine from other apps - LibreOffice docs, Cherry Tree, etc.
  • If I set Firefox as the default browser, that works fine whether or not Firefox is running when I click the link.
  • I have two different profiles in Thunderbird; the problem is the same regardless of which profile I load at startup.

Please note that this is not a problem with the default/preferred browser; it has only to do with whether Chrome is already open or not when a link is clicked in Thunderbird.

Even though this is not actually a preferred browser issue, I tried all the various suggestions I could find related to problems with the correct browser launching for Thunderbird links; none of them made any difference. In all cases, the settings worked as they should if Chrome was already open when I clicked the link, and didn't work if it wasn't open:

  • Changing network.protocol-handler.warn-external.http & .https to true, and then manually choosing Chrome when prompted to pick app to open link
  • adding a user.js file specifying the browser to use
  • Specifying Chrome as the app for http and https in Incoming Attachments

I'm at a loss. I would be very grateful if anyone has any suggestions for how to troubleshoot this further.

0

I was unable to ever find the cause of this problem, but I was able to resolve it. Incidentally, I upgraded from 16.04 to 17.04 (for unrelated reasons), and that had no effect on the problem.

This is the process I followed; even though it didn't provide an answer for what was wrong, I am including here in case it helps anyone else who needs to troubleshoot a similar problem:

  • Made copies of both of my Thunderbird profiles.
  • Purged Chrome and Thunderbird ($ sudo apt-get purge google-chrome* and $ sudo apt-get purge thunderbird)
  • Re-installed Chrome first; because of the prevalence of reported problems with Thunderbird recognizing Chrome as the default browser, I wanted to make sure Chrome was installed and set as default before installing Thunderbird. I used the install process described in AskUbuntu question 510056 (the first answer, written by Pandya; even though it is several years old, it is still applicable).
  • Re-installed Thunderbird ($ sudo apt-get install thunderbird).
  • Tested using default profile, configured only enough to allow me to access an email to test with. Test was successful; link from email opened in Chrome, without Chrome running beforehand.
  • Copied one of my old profiles over default. Test was successful, indicating that this profile was not the cause of the problem.
  • Used profile manager ($ thunderbird -ProfileManager) to create a new profile, and copied my second old profile over it. Tested using second profile. This test was also successful, indicating that neither profile was the source of the orignial problem.
  • Renamed profiles to same as they were before, and copied the old Thunderbird profiles.ini over the new one. Test was successful, indicating there was nothing amiss with the profiles.ini.
  • Re-enabled all my original extensions and plug-ins in Chrome. Test was successful.

So the only conclusion I can come to is that there was something amiss with the Thunderbird installation, and that the re-install resolved the issue. Fortunately, being able to easily save and replace the profiles made re-install relatively painless.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.