0

On my dual boot machine with Windows 10 x64 and Ubuntu 16.04 x64, I have been plagued with Wi-Fi dropping my internet connection while the indicator always says I'm still connected.

This is an ongoing problem since I reinstalled Ubuntu 16.04.

I forgot how I had fixed this issue in the past, since it was a couple years ago. And I tried to retrace my steps but have unfortunately steered off my path.

Internet one minute, no Internet the next minute, and so on.

I literally cannot load more than 2 web-pages before this happens, even after rebooting or running sudo service network-manager restart.

I have downloaded and compiled iwfinger's rtlwifi-new drivers which installs successfully, as well as rtlwifi-new-dkms from hanipouspilot's PPA which returns a dkms error on Ubuntu 16.04, but still no luck.

I made sure my router is WPA2 AES, I also played with the router settings making it 'wireless G only' 'wireless N only' and selecting different wireless channels, and selecting '20Ghz only'. Still no luck.

I even disabled ipv6 and setting it to link local only in Ubuntu Wi-Fi settings. No luck.

Here's an output of a ping session:

64 bytes from 8.8.8.8: icmp_seq=295 ttl=58 time=33.9 ms
ping: sendmsg: No buffer space available
ping: sendmsg: No buffer space available
ping: sendmsg: No buffer space available
ping: sendmsg: No buffer space available
From 192.168.1.100 icmp_seq=157 Destination Host Unreachable
From 192.168.1.100 icmp_seq=158 Destination Host Unreachable
From 192.168.1.100 icmp_seq=159 Destination Host Unreachable

Here's the output of lspci -knn | grep Net -A3:

04:00.0 Network controller [0280]: Realtek Semiconductor Co., Ltd. 
RTL8821AE 802.11ac PCIe Wireless Network Adapter [10ec:8821]
    DeviceName: Realtek(R) RTL-8111GA Gigabit Network Connection
    Subsystem: AzureWave RTL8821AE 802.11ac PCIe Wireless Network Adapter 
[1a3b:216b]
    Kernel driver in use: rtl8821ae
    Kernel modules: rtl8821ae

And here's some output of 'dmesg':

14.545968] acer_wmi: Acer Laptop ACPI-WMI Extras

[ 14.545998] acer_wmi: No WMID device detection method found

--->[ 14.715548] rtl8821ae 0000:04:00.0 wlo1: renamed from wlan0

[ 15.607397] Adding 8308732k swap on /dev/sda6. Priority:-1 extents:1 across:8308732k FS

[ 16.240388] input: HDA NVidia HDMI/DP,pcm=3 as /devices/pci0000:00 /0000:00:02.1/0000:01:00.1/sound/card1/input14

[ 16.240455] input: HDA NVidia HDMI/DP,pcm=7 as /devices/pci0000:00 /0000:00:02.1/0000:01:00.1/sound/card1/input15

[ 16.240507] input: HDA NVidia HDMI/DP,pcm=8 as /devices/pci0000:00/0000:00:02.1/0000:01:00.1/sound/card1/input16

[ 16.240559] input: HDA NVidia HDMI/DP,pcm=9 as /devices/pci0000:00/0000:00:02.1/0000:01:00.1/sound/card1/input17

[ 17.001306] audit: type=1400 audit(1511393234.729:2): apparmor="STATUS" operation="profile_load" profile="unconfined" name="/sbin/dhclient" pid=808 comm="apparmor_parser"

[ 17.001309] audit: type=1400 audit(1511393234.729:3): apparmor="STATUS" operation="profile_load" profile="unconfined" name="/usr/lib/NetworkManager/nm-dhcp-client.action" pid=808 comm="apparmor_parser"

[ 17.001310] audit: type=1400 audit(1511393234.729:4): apparmor="STATUS" operation="profile_load" profile="unconfined" name="/usr/lib/NetworkManager/nm-dhcp-helper" pid=808 comm="apparmor_parser"

[ 17.001311] audit: type=1400 audit(1511393234.729:5): apparmor="STATUS" operation="profile_load" profile="unconfined" name="/usr/lib/connman/scripts/dhclient-script" pid=808 comm="apparmor_parser"

[ 17.001607] audit: type=1400 audit(1511393234.729:6): apparmor="STATUS" operation="profile_load" profile="unconfined" name="/usr/lib/lightdm/lightdm-guest-session" pid=807 comm="apparmor_parser"

[ 17.001610] audit: type=1400 audit(1511393234.729:7): apparmor="STATUS" operation="profile_load" profile="unconfined" name="/usr/lib/lightdm/lightdm-guest-session//chromium" pid=807 comm="apparmor_parser"

[ 17.003045] audit: type=1400 audit(1511393234.729:8): apparmor="STATUS" operation="profile_load" profile="unconfined" name="/usr/sbin/cups-browsed" pid=813 comm="apparmor_parser"

[ 17.003116] audit: type=1400 audit(1511393234.729:9): apparmor="STATUS" operation="profile_load" profile="unconfined" name="/usr/lib/snapd/snap-confine" pid=812 comm="apparmor_parser"

[ 17.003117] audit: type=1400 audit(1511393234.729:10): apparmor="STATUS" operation="profile_load" profile="unconfined" name="/usr/lib/snapd/snap-confine//mount-namespace-capture-helper" pid=812 comm="apparmor_parser"

[ 17.004071] audit: type=1400 audit(1511393234.733:11): apparmor="STATUS" operation="profile_load" profile="unconfined" name="/usr/sbin/ippusbxd" pid=815 comm="apparmor_parser"

[ 17.665896] Bluetooth: BNEP (Ethernet Emulation) ver 1.3

[ 17.665898] Bluetooth: BNEP filters: protocol multicast

[ 17.665903] Bluetooth: BNEP socket layer initialized

[ 20.503238] IPv6: ADDRCONF(NETDEV_UP): wlo1: link is not ready

[ 20.804455] IPv6: ADDRCONF(NETDEV_UP): wlo1: link is not ready

[ 20.808620] IPv6: ADDRCONF(NETDEV_UP): enp2s0: link is not ready

[ 20.923403] r8169 0000:02:00.0 enp2s0: link down

[ 20.923473] IPv6: ADDRCONF(NETDEV_UP): enp2s0: link is not ready

[ 21.313375] IPv6: ADDRCONF(NETDEV_UP): wlo1: link is not ready

[ 27.895271] wlo1: authenticate with 00:25:9c:f0:e9:3f

[ 27.900825] wlo1: send auth to 00:25:9c:f0:e9:3f (try 1/3)

[ 27.903455] wlo1: authenticated

[ 27.904029] wlo1: associate with 00:25:9c:f0:e9:3f (try 1/3)

[ 27.921114] wlo1: RX AssocResp from 00:25:9c:f0:e9:3f (capab=0x431 status=0 aid=2)

[ 27.922121] wlo1: associated

[ 27.922166] IPv6: ADDRCONF(NETDEV_CHANGE): wlo1: link becomes ready

[ 31.216712] Bluetooth: RFCOMM TTY layer initialized

[ 31.216721] Bluetooth: RFCOMM socket layer initialized

[ 31.216726] Bluetooth: RFCOMM ver 1.11

--->[ 224.668780] wlo1: deauthenticating from 00:25:9c:f0:e9:3f by local choice (Reason: 3=DEAUTH_LEAVING)

[ 242.894235] IPv6: ADDRCONF(NETDEV_UP): wlo1: link is not ready

[ 242.900342] IPv6: ADDRCONF(NETDEV_UP): enp2s0: link is not ready

[ 243.002770] IPv6: ADDRCONF(NETDEV_UP): wlo1: link is not ready

[ 277.392984] wlo1: authenticate with 00:25:9c:f0:e9:3f

[ 283.048317] wlo1: send auth to 00:25:9c:f0:e9:3f (try 1/3)

[ 283.052142] wlo1: authenticated

[ 283.056441] wlo1: associate with 00:25:9c:f0:e9:3f (try 1/3)

[ 283.075720] wlo1: RX AssocResp from 00:25:9c:f0:e9:3f (capab=0x431 status=0 aid=2)

[ 283.078113] wlo1: associated

[ 283.078189] IPv6: ADDRCONF(NETDEV_CHANGE): wlo1: link becomes ready

I could be wrong since I'm not an expert, but some lines in 'dmesg' appear to be telling me that "wlo1" seems to be trying to re-authenticate over again. But I could be wrong. It also says 'link not ready' multiple times. Perhaps somebody can check it out who has more experience.

But for the time being, my Ubuntu is basically unusable when it comes to wireless.

Thanks in advance.

  • 3
    You know, doing the same thing over and over and expect different results is the very definition of insanity. Now, please edit your question and add output of lspci -knn | grep Net -A3 terminal command. This way we can identify your WiFi device and drivers in case there's something wrong with it. Meanwhile check your router and assure the wireless encryption settings are no other than WPA2-AES. – user692175 Nov 20 '17 at 23:32
0

You could try to add some argument during the driver module loading.

sudo nano /etc/modprobe.d/rtl8821ae.conf

And paste the following line and finally restart.

options rtl8821ae int_clear=0 fwlps=0 ips=0

Just delete the file in case of the stability is not better.

Source : https://github.com/lwfinger/rtlwifi_new/issues/235

0

I had similar problem for months (the wifi hardware worked, as I had no problem with wifi in the same dual boot laptop when use window 10). None of those methods I found online such as editing /etc/modprobe.d/rtl8821ae.conf, or /etc/modprobe.d/wifi.conf, or /etc/pm/config.d/config ever resolved the problem. None of them did, until I read a solution to update the driver: https://medium.com/@elmaxx/rtl8821ae-wifi-drivers-in-ubuntu-16-04-4c1286524afa Finally solved this nagging wifi dropping problem!

The commands you need are:

sudo apt-get install linux-headers-generic build-essential git
git clone http://github.com/lwfinger/rtlwifi_new.git
cd rtlwifi_new; make; sudo make install

Hope this also resolves your problem.

Edit: After the driver update, I still encountered some drop in wifi (although far less frequently). After some further study, this link https://help.ubuntu.com/community/WICD finally resolves my long nagging wifi problem fully. In summary, update rtl wifi driver, and replace NetworkManager by WICD.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.