The screen goes blank and shows logs me out immediately a while after using multiple monitors.

dmesg shows:

[33786.908877] [drm:atom_op_jump [radeon]] *ERROR* atombios stuck in loop for more than 5secs aborting
[33786.908901] [drm:atom_execute_table_locked [radeon]] *ERROR* atombios stuck executing 6DD2 (len 254, WS 0, PS 4) @ 0x6DE0
[33786.908910] [drm:atom_execute_table_locked [radeon]] *ERROR* atombios stuck executing 673E (len 78, WS 12, PS 8) @ 0x6777

lspci | grep -E 'VGA|Display' shows:

00:02.0 VGA compatible controller: Intel Corporation HD Graphics 5500 (rev 09)
03:00.0 Display controller: Advanced Micro Devices, Inc. [AMD/ATI] Sun 
XT [Radeon HD 8670A/8670M/8690M / R5 M330 / M430] (rev 83)

This post explains exactly my situation. But I don't have /etc/modprobe.d/radeon.conf file.

7 Answers 7


I get the same error with the amdgpu driver. But my computer completely freezes and I have to hard reset it. If you do not need the AMD GPU, you can blacklist the radeon (or amdgpu) module. It fixes the error but then the AMD GPU cannot be used.

Just create a file in /etc/modprobe.d/ (I usually call it blacklist.conf) and add blacklist radeon (or amdgpu).

To check if it was really disabled, you can run lsmod | grep radeon. It should not display anything.

  • I chose this method with modprobe.blacklist=radeon in kernel boot parameter (grub). Other kernel boot parameters worked too : nomodeset=1 ; acpi=off ; radeon.modeset=0.
    – Max
    Sep 17, 2019 at 14:54

In my situation, I remove the tlp package by running

sudo apt remove tlp
  • This saved my day.
    – Mehraban
    Jun 1, 2018 at 20:35
  • 1
    Maybe I'm wrong, but tlp is a tool for power saving. Simply removing it doesn't sound like a good solution to me.
    – Natjo
    Sep 11, 2018 at 7:40

Same problem with my mother's laptop. Was updating without a problem for years.

lspci | grep -E 'VGA|Display' shows:

01:00.0 VGA compatible controller: Advanced Micro Devices, Inc. [AMD/ATI] RV620/M82 [Mobility Radeon HD 3450/3470]

tlp is not installed in the sytem. And I don't have /etc/modprobe.d/radeon.conf

Booting from the old 4.4 kernel gave no problem. But 4.15.0-32 did

I tried adding bootflags radeon.drm=0 without result. radeon: unknown parameter 'drm' ignored

I was successfull using the blunt axe approach by disabling all powermanagement with acpi=off apm=off

But ended up using the previous kernel by adding GRUB_DEFAULT="1>2" to grub.conf (see http://techadminblog.com/boot-previous-kernel-version-ubuntu-16-04/ for more info

This is how you add the bootflags in grub.conf

GRUB_CMDLINE_LINUX_DEFAULT="nosplash debug --verbose acpi=off apm=off"

IMPORTANT! after editing grub.conf you have to run sudo update-grub and reboot

  • Yes, it does. It provides 2 ways to solve the problem in my case. I deleted the question in the end asking if someone knows a better way to solve the problem.
    – varta
    Aug 23, 2018 at 6:37

In my case disabling radeon power management solved the problem ( turning off acpi prevented trackpad from working ):

  1. Edit '/etc/default/grub' and add 'radeon.runpm=0' to GRUB_CMDLINE_LINUX variable, it will look something like:

    GRUB_CMDLINE_LINUX="... quiet radeon.runpm=0"
  2. Update Grub with:

    sudo update-grub
  3. Reboot your computer.

  • if you have [drm:radeon_pm_resume [radeon]] *ERROR* radeon: dpm resume failed line in your dmesg, this should help as it did for me
    – outoftime
    Feb 5, 2021 at 16:03

I Had a lot of trouble with this. The last screen message was "switching to amdgpudrmfb from EFI VGA" But after login with ssh and dmesg I've got the same of you "error atombios stuck in loop"

My goal was to activate amdgpu driver instead of radeon So the kernel params that worked on grub was:

amdgpu.runpm=0 amdgpu.dpm=0 amdgpu.dc=0 radeon.si_support=0 radeon.cik_support=0 amdgpu.si_support=1 amdgpu.cik_support=1

I have kernel 5.4.0-40-lowlatency Under Ubuntu 20.04 And my Video is an Radeon R9 280x, and from this wiki https://wiki.gentoo.org/wiki/AMDGPU

My firmware is the TAHITI I Hope this can save someone else hours!


Here is a complete solution for REHL. It worked for me. The solution is to blacklist the radeon module. For ubuntu some of the commands might different.



I found that the issue was already reported long time back to Kernel.org here: https://bugzilla.kernel.org/show_bug.cgi?id=51381.

The solution is to add radeon.runpm=0 flag to the kernel boot options.


You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .