1

I can't change resolution 2560x1080.

Notebook HP Probook 6560B. (i5 2540m, integrated graphics intel hd3000)

The Notebook has only integrated graphics card.

Monitor connected via cable Display Port => HDMI.

In settings, I have only full-hd resolution 1920x1080.

default settings with 1920x1080 screenshot

Settings is not has 2560x1080 resolution.

I installed proprietary drivers from intel site => Intel graphics utility for 16.04

I tried set custom resolution from this link => set custom resolution

Output from xrandr =>

Screen 0: minimum 320 x 200, current 3286 x 1080, maximum 8192 x 8192
LVDS-1 connected primary 1366x768+1920+0 (normal left inverted right x axis y axis) 344mm x 194mm
   1366x768      59.99*+  39.94  
   1360x768      59.80    59.96  
   1024x768      60.04    60.00  
   960x720       60.00  
   928x696       60.05  
   896x672       60.01  
   960x600       60.00  
   960x540       59.99  
   800x600       60.00    60.32    56.25  
   840x525       60.01    59.88  
   800x512       60.17  
   700x525       59.98  
   640x512       60.02  
   720x450       59.89  
   640x480       60.00    59.94  
   680x384       59.80    59.96  
   576x432       60.06  
   512x384       60.00  
   400x300       60.32    56.34  
   320x240       60.05  
VGA-1 disconnected (normal left inverted right x axis y axis)
HDMI-1 disconnected (normal left inverted right x axis y axis)
DP-1 disconnected (normal left inverted right x axis y axis)
HDMI-2 disconnected (normal left inverted right x axis y axis)
HDMI-3 connected 1920x1080+0+0 (normal left inverted right x axis y axis) 673mm x 284mm
   1920x1080     60.00*   50.00    59.94  
   1920x1080i    60.00    50.00    59.94  
   1680x1050     59.88  
   1600x900      60.00  
   1280x1024     75.02    60.02  
   1152x864      75.00  
   1280x720      60.00    50.00    59.94  
   1024x768      75.03    60.00  
   800x600       75.00    60.32  
   720x576       50.00  
   720x480       60.00    59.94  
   640x480       75.00    60.00    59.94  
   720x400       70.08  
DP-2 disconnected (normal left inverted right x axis y axis)
DP-3 disconnected (normal left inverted right x axis y axis)

My steps:

gtf 2560 1080 60
xrandr --newmode "TEST" 230.76 2560 2728 3000 3440 1080 1081 1084 1118 -HSync +Vsync
xrandr --addmode HDMI-3 "TEST"
xrandr --output HDMI-3 --mode "TEST"

After these steps resolution not changed.

xrandr with verbose:

xrandr --output HDMI-3 --mode "TEST" --verbose
crtc 1:         TEST  60.00 +0+0 "HDMI-3"
xrandr: Configure crtc 1 failed
crtc 0: disable
crtc 1: disable
screen 0: revert
crtc 0: revert
crtc 1: revert

In the settings appears resolution for 2560x1080, and when I trying set this resolution, the image is becoming broken and appearing two errors.

New resolution =>

new resolution screenshot

First Error =>

Error screenshot

Second Error =>

Error screenshot

Also, I tried to connect via ATcom adapter, and I didn't get the result. Resolution left to 1920x1080.

atcom screenshot

I installed windows 7 on this notebook and drivers for video card. The monitor is working correctly with resolution 2560x1080.

  • How much memory is assigned to graphics in your BIOS configuration? You may not have enough assigned to support the higher resolution. Also, this may be a bug in the Intel drivers that just has not been hit with that CPU by anyone else yet, and should likely be reported upstream. – dobey Nov 20 '17 at 19:51
  • Solved. I set the refresh rate to 50 Hz, and the monitor is started working correctly. gtf 2560 1080 50 xrandr --newmode "TEST" 188.60 2560 2704 2976 3392 1080 1081 1084 1112 -HSync +Vsync xrandr --addmode HDMI-3 "TEST" xrandr --output HDMI-3 --mode "TEST" – Kirill Tolmachev Nov 21 '17 at 11:49
  • 1
    Do not add [solved] to the title or post the answer in the question; that's not how things work here. If you have an answer, post it as one. – fkraiem Nov 21 '17 at 12:39
  • I added the answer. – Kirill Tolmachev Nov 21 '17 at 14:07
1

SOLUTION:

When I set update frequency to 50Hz, the monitor is started working correctly.

Steps:

gtf 2560 1080 50

# 2560x1080 @ 50.00 Hz (GTF) hsync: 55.60 kHz; pclk: 188.60 MHz
  Modeline "2560x1080_50.00"  188.60  2560 2704 2976 3392  1080 1081 1084 1112  -HSync +Vsync

    xrandr --newmode "TEST" 188.60  2560 2704 2976 3392  1080 1081 1084 1112  -HSync +Vsync
    xrandr --addmode HDMI-3 "TEST"
    xrandr --output HDMI-3 --mode "TEST"

I added a script to autoload resolution with start system.

I got script from there => Script for autoload resolution

I created file .xprofile and changed script for my needs:

#!/bin/sh
MODE_NAME="ULTRAWIDE"
OUTPUT="HDMI-3"
CONNECTED_OUTPUT=$(xrandr --current | grep -i $OUTPUT | cut -f2 -d' ')

if [ "$CONNECTED_OUTPUT" == "connected" ];
then
# SET 2560x1080 50 HZ
xrandr --newmode "$MODE_NAME" 188.60  2560 2704 2976 3392  1080 1081 1084 1112  -HSync +Vsync
xrandr --addmode HDMI-3 "$MODE_NAME"
else
   echo "ULTRAWIDE IS NOT DETECTED !"
fi
  • No working for me :( => xrandr: Configure crtc 2 failed – angelcervera Aug 22 '18 at 20:46
0

Tks!

I added two commands in .xconfig:

To open: sudo gedit ~/.xprofile

#!/bin/sh
MODE_NAME="ULTRAWIDE"
OUTPUT="HDMI-3"
CONNECTED_OUTPUT=$(xrandr --current | grep -i $OUTPUT | cut -f2 -d' ')

if [ "$CONNECTED_OUTPUT" == "connected" ];
then
# SET 2560x1080 50 HZ
xrandr --newmode "$MODE_NAME" 188.60  2560 2704 2976 3392  1080 1081 1084 1112  -HSync +Vsync
xrandr --addmode HDMI-3 "$MODE_NAME"
xrandr --output HDMI-3 --mode "$MODE_NAME"
xrandr --output HDMI-3 --primary
else
   echo "ULTRAWIDE IS NOT DETECTED !"
fi

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.