15

Using Firefox quantum 57 and Ubuntu 17.10, I am unable to scroll a web page by touching the screen and sliding the page. However this works in Chrome browser.

How to make touch-screen scrolling work in Firefox Quantum?

18

The same solution for Firefox 50 and Ubuntu 16.xx still works for Firefox Quantum 57 and Ubuntu 17.10: Ubuntu 16 and touchscreen scrolling in FireFox

The solution is to launch firefox using:

env MOZ_USE_XINPUT2=1 firefox

You can make this permanent by modifying the launcher using the following:

sudo sed -i "s|Exec=|Exec=env MOZ_USE_XINPUT2=1 |g" /usr/share/applications/firefox.desktop

To undo this change, use:

sudo sed -i "s|Exec=env MOZ_USE_XINPUT2=1 |Exec=|g" /usr/share/applications/firefox.desktop

Comparing touch scrolling in Firefox Quantum, using this solution. with touch scrolling in Chrome:

  • Scrolling is one finger only; two finger scrolling causes the web page to zoom. This is different from Chrome, where you can scroll using two fingers, but still pinch to zoom or un-zoom.
  • You can only scroll vertically or horizontally, depending on which direction your initial motion is in; this is different from Chrome, where you can scroll horizontally or vertically (or in circles) without lifting your finger(s).
  • YOU ARE A GOD PJ!!! I've been searching for how to do that for 2 months now and using half baked extensions for touch dragging that really didn't work that well. Funny thing is that I came across this answer while searching for something completely different... Thanks! – thebunnyrules Jan 22 '18 at 22:45
  • After a bit of testing, it seems to be too unstable to be usable, probably why it's still off by default. It works great at first but as soon as you long click to select text, it makes a context menu popup and things turn really buggy after that. Ah well. Probably a work in progress. – thebunnyrules Jan 22 '18 at 23:25
  • @thebunnyrules I think I'm having the same problem as you, check out bugzilla.mozilla.org/show_bug.cgi?id=1451587 if you have the chance. – Steven Ruppert Apr 5 '18 at 1:12
  • @blendmaster When I use FF wayland, the instability goes away. The popup menu still clashes with caret but a double tap can be used instead of a long press to call it. For X11, I just disabled long press for context menu as a temp solution. I can tell you how to do so if you know how to compile ff. – thebunnyrules Apr 9 '18 at 23:43
  • Thanks for the details @thebunnyrules . If you can post the patch somewhere for disabling long press that'd be helpful. Might be able to add debugging info for the issue as well. – Steven Ruppert Apr 14 '18 at 18:56

protected by Community Sep 24 '18 at 10:23

Thank you for your interest in this question. Because it has attracted low-quality or spam answers that had to be removed, posting an answer now requires 10 reputation on this site (the association bonus does not count).

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged or ask your own question.