1

I installed dnscrypt-proxy from the repo. I didn't touch any config. Here's the error message

$ systemctl  status dnscrypt-proxy.service
● dnscrypt-proxy.service - DNSCrypt client proxy
   Loaded: loaded (/lib/systemd/system/dnscrypt-proxy.service; enabled; vendor preset: enabled)
   Active: failed (Result: exit-code) since ; 10s ago
     Docs: man:dnscrypt-proxy(8)
  Process: 20935 ExecStart=/usr/sbin/dnscrypt-proxy /etc/dnscrypt-proxy/dnscrypt-proxy.conf (code=exited, status=1/FAILURE)
 Main PID: 20935 (code=exited, status=1/FAILURE)

systemd[1]: dnscrypt-proxy.service: Unit entered failed state.
systemd[1]: dnscrypt-proxy.service: Failed with result 'exit-code'.
systemd[1]: dnscrypt-proxy.service: Service hold-off time over, scheduling restart.
systemd[1]: Stopped DNSCrypt client proxy.
systemd[1]: dnscrypt-proxy.service: Start request repeated too quickly.
systemd[1]: Failed to start DNSCrypt client proxy.
systemd[1]: dnscrypt-proxy.service: Unit entered failed state.
systemd[1]: dnscrypt-proxy.service: Failed with result 'exit-code'.

$ cat /lib/systemd/system/dnscrypt-proxy.service
[Unit]
Description=DNSCrypt client proxy
Documentation=man:dnscrypt-proxy(8)
Requires=dnscrypt-proxy.socket
After=network.target
Before=nss-lookup.target

[Install]
Also=dnscrypt-proxy.socket
WantedBy=multi-user.target

[Service]
Type=notify
NonBlocking=true
User=_dnscrypt-proxy
ExecStart=/usr/sbin/dnscrypt-proxy /etc/dnscrypt-proxy/dnscrypt-proxy.conf
Restart=always
ProtectSystem=strict
ProtectHome=true
ProtectKernelModules=true
ProtectKernelTunables=true
ProtectControlGroups=true
MemoryDenyWriteExecute=true
RestrictRealtime=true

Edit: OS restart somehow solve it.
Edit: Nope, after another restarts, issue comes back again. Tried systemctl restart and OS restart.

  • If you have solved your problem, please post an answer instead of editing the question. – muru Nov 20 '17 at 10:56
1

Found the issue from journalctl -xe. I enabled the BlockIPv6 yes option which requires extra plugin.
sudo apt install dnscrypt-proxy-plugins solved it.

Your Answer

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.