0

Please someone help me with the installation of oracle jdev. The instructions in the internet only support the old versions. The new version has a .bin file and a folder which contains some other installation data and I don't know what to do with that folder! I tried this commands which caused error..

chmod 777 jdev_suite_122130_linux64.bin
sudo ./jdev_suite_122130_linux64.bin

This is the error:

ERROR: Installer execution failed (1).
3
  • 1
    run it like this ./jdev_suite_122130_linux64.bin remove the sudo Nov 19, 2017 at 18:36
  • @George I tried this one but it doesn't make any difference.
    – Mina Fa
    Nov 20, 2017 at 8:56
  • Is this the entire output of sudo ./jdev_suite_122130_linux64.bin? Nov 24, 2017 at 14:18

1 Answer 1

2

To set up the installer if required the right command should have been: chmod +x jdev_suite_122130_linux64.bin. But nonetheless, run it without sudo:

./jdev_suite_122130_linux64.bin

Next time check whether it's executable with:

ls -l jdev_suite_122130_linux64.bin

Excerpts from here

Below are some additional considerations to make prior to running the installer:

  • On UNIX operating systems, Oracle recommends that you set the umask to 027 on your system prior to installation. This ensures that file permissions will be set properly during installation. Use the following command:

    umask 027
    
    • You must enter this command in the same terminal window from which you plan to run the product installer.
  • On UNIX operating systems, do not run the installation program as the root user. The installer startup validation will fail and you will not be able to continue.

  • When managing a product installation (for example, applying patches, or starting Managed Servers), you must use the same user ID as was used to perform the initial product installation.

From the above the new permissions you set 777 will not let the installer go forward. Hence you need to take it back to the default then follow the instructions above in the excerpt. The was o requirement to change the permissions in the first place. If you downloaded the zip file then unzip again and check the permissions with ls -l <file_name>. Armed with this information you can now follow the recommended way to run the installer.

See page 15 here

8
  • I tried it and this error appears again : Launcher log file is /tmp/OraInstall2017-11-20_12-22-40PM/launcher2017-11-20_12-22-40PM.log. Extracting the installer . . . . Done Self extraction to /tmp/sfx_KsxhGM failed. The log is located here: /tmp/OraInstall2017-11-20_12-22-40PM/launcher2017-11-20_12-22-40PM.log. ERROR: Installer execution failed (1).
    – Mina Fa
    Nov 20, 2017 at 8:57
  • Please reextract that file and check the default permission on that installer then make executable if not already then try again Nov 20, 2017 at 9:06
  • Or let me see the default permission o. It. Nov 20, 2017 at 9:11
  • How should I see the default permission?
    – Mina Fa
    Nov 20, 2017 at 9:18
  • 1
    I think the problem is because jdev has 2 files for installation.. that zip which is 450Mb is called disk 2 and the oracle webpage says both files (.bin file and .zip file) is required for installing. But when I try to run the files only .bin file is shown in terminal.
    – Mina Fa
    Nov 20, 2017 at 21:46

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .