1

I was surfing the Internet, and suddenly (I didn't do anything, did change any settings, only were using browser) - Interned disappeared. I thought something with the router, I rebooted it, then my phone and the other Ubuntu-PC successfully reconnected, but my notebook Can not access any server. Looks like there is no Internet.

But if I start expressvpn connect it can successful access its servers and establish the connection, and than my browser can show web pages.

What happened, how to reset this behavior? I can not access Internet with VPN being connected.

I tried this How do I reset my Network settings to default? - doesn't work, can see any wifi networks. Also I flushed /etc/network/interfaces - doesn't help.

I tried reinstall ExpressVPN too - didn't help.

How to get back the default behavior. I don't want reinstall Ubuntu, it's not Windows, when you do it every time something doesn't work, right?

3

Check out How to restore/recreate etc/resolv.conf files

Specifically: sudo apt-get remove --purge resolvconf && sudo apt-get install resolvconf

That fixed it for me!

1

Run sudo apt install resolvconf then disconnect expressvpn

  • 2
    I believe resolvconf is installed by default. If so, this wouldn't do anything. Is resolvconf removed by ExpressVPN installation or something like that? – Chai T. Rex Dec 25 '17 at 2:13
0

Run sudo dpkg-reconfigure resolvconf after disconnecting expressvpn.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.