0

I installed openstack using conjure-up(single node installation - all services of openstack on one server, this is for experimental purposes) and then was able to upload couple of sample images as follows

glance image-create --name "xenial-cloud1" --disk-format qcow2 --container-format bare --file xenial-server-cloudimg-amd64-disk1.img

the size of this image is around 280MB.

Then I proceeded to upload an image of size 12GB which is a ubuntu 16.04 Desktop image with Hawkbit installed on it.

glance image-create --name "ubuntu-16-hawkbit-qcow2" --disk-format qcow2 --container-format bare --file hawkbit-image.qcow2 --progress

It failed at 70% giving the below error

Error finding address for http://ip_of_ glance:9292/v2/images/7dc43b2a-5d42-41fc-acbe-16493f0d8395/file: Unable to establish connection to http://:9292/v2/images/7dc43b2a-5d42-41fc-acbe-16493f0d8395/file

after this even when I try to upload a smaller size image it doesnt work.

All the services are up and running when I check status with the command juju status

Even glance related commands like glance image-list also give the same error

Error finding address for http://ip_of_glance:9292/versions: Unable to establish connection to http://ip_of_glance:9292/versions

Glance service is listening on port 9292 , i sshed into the glance node and ran

ubuntu@juju-64a1f1-4:~$ sudo netstat -plnt | grep ':9292'
tcp        0      0 0.0.0.0:9292            0.0.0.0:*               LISTEN      1682/haproxy
tcp6       0      0 :::9292                 :::*                    LISTEN      1682/haproxy

So am not sure, whats the problem. Any help to resolve this issue will be appreciated.

Note: This is the first time I am using openstack, so am a novice, please bear if ive missed out giving certain details or gone about things in the wrong fashion.

when running lxd init before installing openstack using conjure-up, we chose 27GB as the size of the loop device(it was the default one indicated) storage backend as zfs

UPDATE: When I set the

default_store = file

in /etc/glance/glance-api.conf

I am able to upload an image which is really small like 13MB or so but a bigger image throws me an error described here : https://ask.openstack.org/en/question/27033/image-storage-media-is-full/, thats because I don't have enough space on filesystem_store_datadir = /var/lib/glance/images/

I figured that my initial default_store was set to rbd after I finished installation using conjure-up, which is related to ceph. Also I've notice that ceph.service is active but in exited state, I tried to restart it but it wont leave the exited state

ceph.service loaded active exited LSB: Start Ceph distributed file system daemons at boot time

If I can get this to be working, I'm sure things will return to normal from where I left off when I could upload two images successfully (when file store was set to rbd)

Is it possible to increase the space in /var/lib/glance/images/ post installation or even point filesystem_store_datadir to another machines path which has space on it ?

1
  • I was able to mount a location in my server which had space , gave that path in the glance api conf file and was able to store created images in the file system – Abbas Nov 20 '17 at 6:35
0

allow connections from "ip_of_glance to port 9292/tcp and 9292/udp.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.