I am currently unable to remove authentication keys in Ubuntu 17.10. Going on the Software & Update panal and selecting "remove" on the authentication keys I wish to remove does nothing.

I tried removing the keys using the sudo command found in Removing Trusted software providers from 'Software & Updates' but this too does not remove the keys (return message is "ok" but key is not removed).

Any help with this appreciated.

  • 1
    Please edit your question to update it with additional info, rather than posting it in comments.
    – dobey
    Nov 19, 2017 at 2:21

2 Answers 2


You normally should be able to use:

sudo apt-key del <KEY_ID>

But if that fails you can search for the corresponding key file in /etc/apt/trusted.gpg.d and delete the two files for it there.

Here an example, lets say you have installed the tor browser from ppa:webupd8team. After uninstalling this package and removing the source files for it from /etc/apt/sources.list.d/ you still have the two keys in /etc/apt/trusted.gpg.d named

-rw-r--r-- 1 root root  507 Okt 21 23:36 webupd8team_ubuntu_tor-browser.gpg
-rw-r--r-- 1 root root    0 Okt 21 23:36 webupd8team_ubuntu_tor-browser.gpg~

Now remove both keys by:

sudo rm /etc/apt/trusted.gpg.d/webupd8team_ubuntu_tor-browser*

And you should be done with them. you can verify this by opening Software&Updates and check on the 'Other Software' tab. They key should be gone. you can find the proper file name as well with apt-key list the output for this key I used as example looks like this

pub   rsa1024 2010-05-04 [SC]
      7B2C 3B08 89BF 5709 A105  D03A C251 8248 EEA1 4886
uid           [ unknown] Launchpad VLC

You see the name of the key file is stated above the key itself.

  • 1
    This worked for 1 of the keys, but two more do not appear in /etc/apt/trusted.gpg.d. I found them in /etc/apt/sources.list.d
    – Berrik
    Nov 19, 2017 at 2:31
  • 1
    which ones they are?
    – Videonauth
    Nov 19, 2017 at 2:32
  • 1
    try a reboot, even though I tested this here on my system just before posting my answer and software&updates works fine and apt-key list as well works still without a reboot. Maybe recheck your inputs? Did you delete anything else or mess up the names or paths?
    – Videonauth
    Nov 19, 2017 at 2:40
  • 1
    when they are still in the apt-key list but have no filename anymore above them try sudo apt-key del <KEY>.
    – Videonauth
    Nov 19, 2017 at 2:41
  • 1
    Then please comment on this bug and tell them your situation and what version of Ubuntu you have, and mark yourself affected by this bug too :bugs.launchpad.net/ubuntu/+source/apt/+bug/1481871
    – Videonauth
    Nov 19, 2017 at 2:55
  1. Open Software & Updates
  2. Select the "Authentication" tab
  3. Identify the provider you wish to delete
  4. Identify the string of letters and numbers without spacing just before the date,,, for example the string you need is bold in the following: 005EAE8119BB5BCA 2011-03-16. GUI


  1. Open a Terminal and type:
    sudo apt-key list This should display the same providers as in Software & Updates,, example: Terminal list

  2. Identify and copy (control+shift C)the string of numbers and letters I highlighted in white. You can compare that same data on the Software & Updates GUI if you want to make sure. The GUI will display the data without spaces, and is before the date. Terminal and GUI pic

  3. Enter in the terminal: sudo apt-key del 005E AE81 19BB 5BCA

NOTE: You will have to remove the spaces between the data you just selected and pasted so it will look like the following instead,, at least I had to do it that way: sudo apt-key del 005EAE8119BB5BCA

  1. type in your password then press enter
  2. will say "Ok"
  3. Reenter sudo apt-key list Terminal

Should have the provider deleted and showing the next one on the list as shown in the Software & Updates GUI.


  1. Close and reopen the Software & Updates GUI in order for it to display the updated list,, voila! Should be good result
  • This solution worked well for me. Thank you @andr'oidster. Mar 8, 2019 at 18:25

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.