2

I had an error while installing Discord though Software-Center.

I clicked to install it, then the Software Center said there were an error, and that wasn't possible to install Discord.

So I tried to install Discord again, just clicking at the "Install" button, but this time the Software Center said "Discord Has Alredy Been Installed".

Discord appears in my programs but I'm unable to uninstall it. I want to uninstall it now and install again, avoiding these errors. What should I do?

6
  • 2
    If you installed from the software-center it is presumably a snap package, you can try sudo snap remove discord Not sure if sudo is needed here.
    – Videonauth
    Nov 18, 2017 at 23:11
  • 1
    Yes, it's a snap ^^^ . You can run the command without sudo, a pop-up will ask for the password.
    – user692175
    Nov 18, 2017 at 23:13
  • 1
    I installed it for testing purposes only and, in 16.04, it worked. Perhaps before giving up you can try in terminal ( type discord then enter) and post the error messages.
    – user692175
    Nov 18, 2017 at 23:15
  • It worked with the Videonauth answer! How can i mark the question as answered?
    – victorrms
    Nov 18, 2017 at 23:18
  • Do you mean you reinstalled and now it works?
    – user692175
    Nov 19, 2017 at 22:52

1 Answer 1

6

Open a terminal by pressing ctrl+alt+t then use the following command to uninstall:

snap remove discord

For reinstalling it use:

snap install discord

If you want to know which snap packages you have installed use:

snap list

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.