1

I'm trying to get Ubuntu to enable Wifi automatically on boot currently I get "Airplane mode" on boot and I have to manually turn on the Wireless adapter

I've created /etc/rc.local (which doesn't exist in Ubuntu 17.10)

printf '%s\n' '#!/bin/bash' 'exit 0' | sudo tee -a /etc/rc.local
sudo chmod +x /etc/rc.local
sudo reboot

and add this commands

sudo ifconfig wlo1 up
sudo service network-manager restart

wlo1 is my wireless adapter connection name

When I turn off my wireless connection I automatically get the Airplane mode (which has a dedicated shortcut in my keyboard FN+F12 that doesn't work) and when I run the the command sudo ifconfig wlo1 up I get this error message SIOCSIFFLAGS: Operation not possible due to RF-kill

There is no option to enable/disable the the Airplane switch via a HW setting in my BIOS as suggested Here

Is there a way to automatically turn on my wireless network upon boot ?

0

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.