While playing World of Warcraft (version, my entire computer freezes. When this happens my computer is completely unresponsive to any and all input, including the reset and power buttons. I have to hard reboot by holding down the power button. This seems to happen randomly; some times right away, some times after an hour or so of playing. It does not seem to coincide with any events in-game (running htop and watch -d sensors, my computer does not seem to be in any distress while playing).

From what I understand wine should not be capable of causing such a catastrophic event, and it may be my graphics driver, but I do not know what to do or how to begin searching for the cause.

Useful information:

wine --version
wine-2.20 (Staging)

I am using the Ubuntu X11 desktop (Wayland was causing issues with the camera).

lspci | grep VGA
01:00.0 VGA compatible controller: Advanced Micro Devices, Inc. [AMD/ATI] Tahiti XT [Radeon HD7970/8970 OEM / R9 280X]

Actual Graphics card is a Radeon HD 7970. I am using the radeon driver.

lscpu | grep 'Model name'
Model name:          Intel(R) Core(TM) i7-3930K CPU @ 3.20GHz

I have tried turning off 'Enable_CSMT for better graphic performance' in winecfg->Staging. I have tried running the 32-bit version of the client. I have tried reducing the graphics intensity.

Any help or advice appreciated.

2 Answers 2


I know it is a very old post but I might have some info to help someone down the line. I had similar problems playing games on wine (either plain wine or via playonlinux).
How to do this might change based on the desktop environment you are using, and even graphics driver options. However what worked for me on KDE and AMD Radeon Vega 64 GPU (open source drivers on Kernel 4.15+) was to:

  1. Disable "Tearing prevention ("vsync") on KDE compositor options
  2. Disable "Allow applications to block compositing" on KDE Compositor options
  3. Other options on KDE compositor options: Enable compositor on startup enabled, scale method accurate, rendering backend OpenGL 2.0.
  4. On playonlinux, make sure GLSL is enabled
  5. If the above is not enough, from the wine game check if you can limit fps to monitor refresh rate, and try to toggle vsync options on and off.

Please note, if you are not using open source drivers, you might need to check and change options on your AMD or NVIDIA control panel as well.

il vipero

  • Thanks for your help, I am using GNOME, but that is still useful to know.
    – CplClegg
    Mar 1, 2018 at 15:32
  • Sorry for slow reply. I believe the freeze was caused by an upstream bug that was fixed in mesa 18.0.1. bugs.freedesktop.org/show_bug.cgi?id=105317. I tested on both Kubuntu and stock Ubuntu and my AMD Radeon Vega 64 is very stable nowadays.
    – il Vipero
    Jul 27, 2018 at 4:14

I never found the root cause, but I was able to fix the issue by installing a new graphics card (Nvidia GTX 1060).

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.