0

I was watching this video tutorial on the .bashrc file and I followed the exact steps in the tutorial on a Lubuntu virtual machine. My problem is that, after editing and saving the file, whenever I open a terminal I get two lines already typed in it at the top:

[1]-  Done                     HISTCONTROL=ignorebothhttps://www.youtube.com/watch?v=pYL0iKIyik4     
[2]+  Done                    index=25  

I think it is weird that the url in the first line is for the exact video tutorial I was watching, although I never included this in the edit. Can anyone explain to me why this happened and how can I remove the two lines? (Undoing the edits in .bashrc doesn't help.)

# ~/.bashrc: executed by bash(1) for non-login shells.
# see /usr/share/doc/bash/examples/startup-files (in the package bash-doc)
# for examples
# If not running interactively, don't do anything

case $- in
*i*) ;;
  *) return;;
esac

# don't put duplicate lines or lines starting with space in the history.
# See bash(1) for more options
HISTCONTROL=ignorebothhttps://www.youtube.com/watch?v=pYL0iKIyik4&index=25&list=PLS1QulWo1RIb9WVQGJ_vh-RQusbZgO_As

# append to the history file, don't overwrite it
shopt -s histappend

# for setting history length see HISTSIZE and HISTFILESIZE in bash(1)
HISTSIZE=1000
HISTFILESIZE=2000

# check the window size after each command and, if necessary,
# update the values of LINES and COLUMNS.
shopt -s checkwinsize

# If set, the pattern "**" used in a pathname expansion context will
# match all files and zero or more directories and subdirectories.
#shopt -s globstar

# make less more friendly for non-text input files, see lesspipe(1)
[ -x /usr/bin/lesspipe ] && eval "$(SHELL=/bin/sh lesspipe)"

# set variable identifying the chroot you work in (used in the prompt below)
if [ -z "${debian_chroot:-}" ] && [ -r /etc/debian_chroot ]; then
debian_chroot=$(cat /etc/debian_chroot)
fi

# set a fancy prompt (non-color, unless we know we "want" color)
case "$TERM" in
xterm-color|*-256color) color_prompt=yes;;
esac

# uncomment for a colored prompt, if the terminal has the capability; turned
# off by default to not distract the user: the focus in a terminal window
# should be on the output of commands, not on the prompt
#force_color_prompt=yes

if [ -n "$force_color_prompt" ]; then
if [ -x /usr/bin/tput ] && tput setaf 1 >&/dev/null; then
# We have color support; assume it's compliant with Ecma-48
# (ISO/IEC-6429). (Lack of such support is extremely rare, and such
# a case would tend to support setf rather than setaf.)
color_prompt=yes
 else
color_prompt=
 fi
 fi

 if [ "$color_prompt" = yes ]; then
 PS1='${debian_chroot:+($debian_chroot)}\[\033[01;32m\]\u@\h\[\033[00m\]:\[\033[01;34m\]\w\[\033[00m\]\$ '
else
PS1='${debian_chroot:+($debian_chroot)}\u@\h:\w\$ '
fi

unset color_prompt force_color_prompt

# If this is an xterm set the title to user@host:dir
case "$TERM" in
xterm*|rxvt*)
PS1="\[\e]0;${debian_chroot:+($debian_chroot)}\u@\h: \w\a\]$PS1"
;;
*)
;;
esac

# enable color support of ls and also add handy aliases
if [ -x /usr/bin/dircolors ]; then
test -r ~/.dircolors && eval "$(dircolors -b ~/.dircolors)" ||eval "$(dircolors -b)"
alias ls='ls --color=auto'
#alias dir='dir --color=auto'
#alias vdir='vdir --color=auto'
alias grep='grep --color=auto'
alias fgrep='fgrep --color=auto'
alias egrep='egrep --color=auto'
fi

# colored GCC warnings and errors
#export GCC_COLORS='error=01;31:warning=01;35:note=01;36:caret=01;32:locus=01:quote=01'

# some more ls aliases
alias ll='ls -alF'
alias la='ls -A'
alias l='ls -CF'

# Add an "alert" alias for long running commands.  Use like so:
#   sleep 10; alert
alias alert='notify-send --urgency=low -i "$([ $? = 0 ] && echo terminal || echo error)" "$(history|tail -n1|sed -e '\''s/^\s*[0-9]\+\s*//;s/[;&|]\s*alert$//'\'')"'

# Alias definitions.
# You may want to put all your additions into a separate file like
# ~/.bash_aliases, instead of adding them here directly.
# See /usr/share/doc/bash-doc/examples in the bash-doc package.

if [ -f ~/.bash_aliases ]; then
. ~/.bash_aliases
fi

# enable programmable completion features (you don't need to enable
# this, if it's already enabled in /etc/bash.bashrc and /etc/profile
# sources /etc/bash.bashrc).
if ! shopt -oq posix; then
if [ -f /usr/share/bash-completion/bash_completion ]; then
. /usr/share/bash-completion/bash_completion
elif [ -f /etc/bash_completion ]; then
. /etc/bash_completion
fi
fi
2
  • Ok I wish I've done that correctly. – Tofi Nov 17 '17 at 20:38
  • 1
    change HISTCONTROL=ignorebothhttps://www.youtube.com/watch?v=pYL0iKIyik4&index=25&list=PLS1QulWo1RIb9WVQGJ_vh-RQusbZgO_As to HISTCONTROL=ignoreboth. You probably have clicked with middleclick after having copying the url for the video. – Videonauth Nov 17 '17 at 20:40
4

Obviously you accidentally copied the video URL to your .bashrc:

HISTCONTROL=ignorebothhttps://www.youtube.com/watch?v=pYL0iKIyik4&index=25&list=PLS1QulWo1RIb9WVQGJ_vh-RQusbZgO_As

Change this line back to

HISTCONTROL=ignoreboth

then save the file and the issue should be gone.

What happened here?

By calling a=b you assign the value b to variable a. Here you filled the following three variables:

HISTCONTROL=ignorebothhttps://www.youtube.com/watch?v=pYL0iKIyik4&
index=25&
list=PLS1QulWo1RIb9WVQGJ_vh-RQusbZgO_As

because for the bash shell & is an operator which separates commands and sends them to the background. But when a command runs in the background only, you don't know when it ends, so bash announces you when it does. As assigning a variable takes place in no time, the first two variable assignments are already done when your terminal emulator finally decided to load, so first thing you see is the kind message that those two processes you accidentally sent to the background are already:

Done
0

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.