0

Upon logging in to system it is clear that a large number of upgrades are available:

258 packages can be updated.
117 updates are security updates.

Output from sudo apt full-upgrade confirms it:

Reading package lists... Done
Building dependency tree       
Reading state information... Done
Calculating upgrade... Done
The following packages were automatically installed and are no longer required:
  libllvm3.8 libllvm3.8:i386 libmircommon5 linux-headers-4.4.0-65 linux-headers-4.4.0-65-generic
  linux-headers-4.4.0-66 linux-headers-4.4.0-66-generic linux-headers-4.4.0-70 linux-headers-4.4.0-70-generic
  linux-headers-4.4.0-71 linux-headers-4.4.0-71-generic linux-headers-4.4.0-72 linux-headers-4.4.0-72-generic
  linux-headers-4.4.0-75 linux-headers-4.4.0-75-generic linux-headers-4.4.0-77 linux-headers-4.4.0-77-generic
  linux-headers-4.4.0-78 linux-headers-4.4.0-78-generic linux-headers-4.4.0-79 linux-headers-4.4.0-79-generic
  linux-headers-4.4.0-81 linux-headers-4.4.0-81-generic linux-headers-4.4.0-83 linux-headers-4.4.0-83-generic
  linux-headers-4.4.0-87 linux-headers-4.4.0-87-generic linux-headers-4.4.0-89 linux-headers-4.4.0-89-generic
  linux-image-4.4.0-65-generic linux-image-4.4.0-66-generic linux-image-4.4.0-70-generic
  linux-image-4.4.0-71-generic linux-image-4.4.0-72-generic linux-image-4.4.0-75-generic
  linux-image-4.4.0-77-generic linux-image-4.4.0-78-generic linux-image-4.4.0-79-generic
  linux-image-4.4.0-81-generic linux-image-4.4.0-83-generic linux-image-4.4.0-87-generic
  linux-image-4.4.0-89-generic linux-image-extra-4.4.0-65-generic linux-image-extra-4.4.0-66-generic
  linux-image-extra-4.4.0-70-generic linux-image-extra-4.4.0-71-generic linux-image-extra-4.4.0-72-generic
  linux-image-extra-4.4.0-75-generic linux-image-extra-4.4.0-77-generic linux-image-extra-4.4.0-78-generic
  linux-image-extra-4.4.0-79-generic linux-image-extra-4.4.0-81-generic linux-image-extra-4.4.0-83-generic
  linux-image-extra-4.4.0-87-generic linux-image-extra-4.4.0-89-generic linux-signed-image-4.4.0-65-generic
  linux-signed-image-4.4.0-66-generic linux-signed-image-4.4.0-70-generic linux-signed-image-4.4.0-71-generic
  linux-signed-image-4.4.0-72-generic linux-signed-image-4.4.0-75-generic linux-signed-image-4.4.0-77-generic
  linux-signed-image-4.4.0-78-generic linux-signed-image-4.4.0-79-generic linux-signed-image-4.4.0-81-generic
  linux-signed-image-4.4.0-83-generic linux-signed-image-4.4.0-87-generic linux-signed-image-4.4.0-89-generic
  snap-confine ubuntu-core-launcher
Use 'sudo apt autoremove' to remove them.
The following NEW packages will be installed
  linux-headers-4.4.0-98 linux-headers-4.4.0-98-generic linux-image-4.4.0-98-generic
  linux-image-extra-4.4.0-98-generic linux-signed-image-4.4.0-98-generic
The following packages will be upgraded:
  apparmor apport apport-gtk apport-retrace bind9-host binutils bluez bluez-cups bluez-obexd ca-certificates cpp-5
  cracklib-runtime crash cryptsetup-bin cups cups-bsd cups-client cups-common cups-core-drivers cups-daemon
  cups-ppdc cups-server-common debootstrap distro-info-data dnsmasq-base dnsutils evince evince-common firefox
  firefox-locale-en flashplugin-installer g++-5 gcc-5 gcc-5-base gcc-5-base:i386 ghostscript ghostscript-x
  gir1.2-gdkpixbuf-2.0 gir1.2-javascriptcoregtk-4.0 gir1.2-packagekitglib-1.0 gir1.2-webkit2-4.0 git git-man
  gnome-software gnome-software-common grub-common grub-efi-amd64 grub-efi-amd64-bin grub-efi-amd64-signed
  grub2-common gvfs gvfs-backends gvfs-bin gvfs-common gvfs-daemons gvfs-fuse gvfs-libs initramfs-tools
  initramfs-tools-bin initramfs-tools-core iproute iproute2 libapparmor-perl libapparmor1 libasan2 libatomic1
  libbind9-140 libbluetooth3 libcc1-0 libcilkrts5 libcrack2 libcryptsetup4 libcups2 libcups2:i386 libcupscgi1
  libcupsimage2 libcupsmime1 libcupsppdc1 libcurl3 libcurl3-gnutls libdns-export162 libdns162 libegl1-mesa
  libevdocument3-4 libevview3-3 libgbm1 libgcc-5-dev libgd3 libgd3:i386 libgdk-pixbuf2.0-0 libgdk-pixbuf2.0-common
  libgfortran3 libgl1-mesa-dri libgl1-mesa-dri:i386 libgl1-mesa-glx libgl1-mesa-glx:i386 libglapi-mesa
  libglapi-mesa:i386 libgles2-mesa libgnutls-openssl27 libgnutls30 libgnutls30:i386 libgomp1 libgraphite2-3 libgs9
  libgs9-common libicu55 libicu55:i386 libidn11 libidn11:i386 libisc-export160 libisc160 libisccc140 libisccfg140
  libitm1 libjavascriptcoregtk-4.0-18 liblouis-data liblouis9 liblsan0 liblwres141 libmirclient9 libmircommon7
  libmircore1 libmirprotobuf3 libmpx0 libmysqlclient20:i386 libnm-gtk-common libnm-gtk0 libnma-common libnma0
  libnss-winbind libnss3 libnss3-1d libnss3-nssdb libosmesa6 libosmesa6:i386 libpackagekit-glib2-16 libpam-systemd
  libpam-winbind libperl5.22 libplist3 libplymouth4 libpoppler-glib8 libpoppler58 libpulse-mainloop-glib0 libpulse0
  libpulse0:i386 libpulsedsp libpython3.5 libpython3.5-minimal libpython3.5-stdlib libquadmath0 libsmbclient
  libsnapd-glib1 libssl-dev libssl-doc libssl1.0.0 libssl1.0.0:i386 libstdc++-5-dev libstdc++6 libstdc++6:i386
  libsystemd0 libsystemd0:i386 libtsan0 libubsan0 libudev-dev libudev1 libudev1:i386 libwayland-client0
  libwayland-cursor0 libwayland-egl1-mesa libwayland-server0 libwbclient0 libwebkit2gtk-4.0-37
  libwebkit2gtk-4.0-37-gtk2 libxatracker2 libxfont1 libxml2 libxml2:i386 libxml2-utils linux-firmware linux-generic
  linux-headers-generic linux-image-generic linux-libc-dev linux-signed-generic linux-signed-image-generic
  logrotate lshw makedumpfile mesa-vdpau-drivers mysql-common network-manager-gnome ntpdate openssl perl perl-base
  perl-modules-5.22 plymouth plymouth-label plymouth-theme-ubuntu-logo plymouth-theme-ubuntu-text poppler-utils
  postfix pulseaudio pulseaudio-module-bluetooth pulseaudio-module-x11 pulseaudio-utils python-apport python-jwt
  python-libxml2 python-problem-report python-samba python3-apport python3-distupgrade python3-jwt python3-louis
  python3-problem-report python3-update-manager python3.5 python3.5-minimal qemu-user-static resolvconf samba
  samba-common samba-common-bin samba-dsdb-modules samba-libs samba-vfs-modules smbclient snap-confine snapd
  snapd-login-service systemd systemd-sysv tcpdump texlive-base texlive-fonts-recommended
  texlive-generic-recommended texlive-latex-base texlive-latex-recommended thunderbird thunderbird-gnome-support
  thunderbird-locale-en thunderbird-locale-en-gb thunderbird-locale-en-us tzdata ubuntu-core-launcher
  ubuntu-desktop ubuntu-drivers-common ubuntu-minimal ubuntu-release-upgrader-core ubuntu-release-upgrader-gtk
  ubuntu-software ubuntu-standard udev update-manager update-manager-core update-notifier update-notifier-common
  wget winbind wpasupplicant xserver-common xserver-xorg-core xul-ext-ubufox
266 to upgrade, 5 to newly install, 0 to remove and 0 not to upgrade.
Need to get 95.1 MB/427 MB of archives.
After this operation, 368 MB of additional disk space will be used.
Do you want to continue? [Y/n] n

Unattended upgrade is running roughly every two days, as shown by the contents of /var/log/unattended-upgrades/unattended-upgrades.log:

2017-11-10 19:11:17,755 INFO Initial blacklisted packages: 
2017-11-10 19:11:17,756 INFO Initial whitelisted packages: 
2017-11-10 19:11:17,756 INFO Starting unattended upgrades script
2017-11-10 19:11:17,756 INFO Allowed origins are: ['o=Ubuntu,a=xenial', 'o=Ubuntu,a=xenial-security', 'o=UbuntuESM,a=xenial']
2017-11-11 14:10:07,827 INFO Initial blacklisted packages: 
2017-11-11 14:10:07,828 INFO Initial whitelisted packages: 
2017-11-11 14:10:07,828 INFO Starting unattended upgrades script
2017-11-11 14:10:07,828 INFO Allowed origins are: ['o=Ubuntu,a=xenial', 'o=Ubuntu,a=xenial-security', 'o=UbuntuESM,a=xenial']
2017-11-14 00:07:21,327 INFO Initial blacklisted packages: 
2017-11-14 00:07:21,328 INFO Initial whitelisted packages: 
2017-11-14 00:07:21,328 INFO Starting unattended upgrades script
2017-11-14 00:07:21,328 INFO Allowed origins are: ['o=Ubuntu,a=xenial', 'o=Ubuntu,a=xenial-security', 'o=UbuntuESM,a=xenial']
2017-11-16 18:47:23,067 INFO Initial blacklisted packages: 
2017-11-16 18:47:23,067 INFO Initial whitelisted packages: 
2017-11-16 18:47:23,067 INFO Starting unattended upgrades script
2017-11-16 18:47:23,068 INFO Allowed origins are: ['o=Ubuntu,a=xenial', 'o=Ubuntu,a=xenial-security', 'o=UbuntuESM,a=xenial']
2017-11-17 12:08:29,321 INFO Initial blacklisted packages: 
2017-11-17 12:08:29,321 INFO Initial whitelisted packages: 
2017-11-17 12:08:29,322 INFO Starting unattended upgrades script
2017-11-17 12:08:29,322 INFO Allowed origins are: ['o=Ubuntu,a=xenial', 'o=Ubuntu,a=xenial-security', 'o=UbuntuESM,a=xenial']

The output from sudo unattended-upgrades --dry-run shows that unattended-upgrades is aware that it needs to install updated packages:

Extract templates from packages: 100%
Preconfiguring packages ...
/usr/bin/dpkg --status-fd 9 --unpack --auto-deconfigure /var/cache/apt/archives/libperl5.22_5.22.1-9ubuntu0.2_amd64.deb /var/cache/apt/archives/perl_5.22.1-9ubuntu0.2_amd64.deb /var/cache/apt/archives/perl-base_5.22.1-9ubuntu0.2_amd64.deb 
/usr/bin/dpkg --status-fd 11 --configure perl-base:amd64 
/usr/bin/dpkg --status-fd 13 --unpack --auto-deconfigure /var/cache/apt/archives/perl-modules-5.22_5.22.1-9ubuntu0.2_all.deb /var/cache/apt/archives/samba-dsdb-modules_2%3a4.3.11+dfsg-0ubuntu0.16.04.11_amd64.deb /var/cache/apt/archives/libnss-winbind_2%3a4.3.11+dfsg-0ubuntu0.16.04.11_amd64.deb /var/cache/apt/archives/libpam-winbind_2%3a4.3.11+dfsg-0ubuntu0.16.04.11_amd64.deb /var/cache/apt/archives/winbind_2%3a4.3.11+dfsg-0ubuntu0.16.04.11_amd64.deb /var/cache/apt/archives/samba_2%3a4.3.11+dfsg-0ubuntu0.16.04.11_amd64.deb /var/cache/apt/archives/samba-common-bin_2%3a4.3.11+dfsg-0ubuntu0.16.04.11_amd64.deb /var/cache/apt/archives/smbclient_2%3a4.3.11+dfsg-0ubuntu0.16.04.11_amd64.deb /var/cache/apt/archives/python-samba_2%3a4.3.11+dfsg-0ubuntu0.16.04.11_amd64.deb /var/cache/apt/archives/samba-vfs-modules_2%3a4.3.11+dfsg-0ubuntu0.16.04.11_amd64.deb /var/cache/apt/archives/samba-libs_2%3a4.3.11+dfsg-0ubuntu0.16.04.11_amd64.deb /var/cache/apt/archives/libwbclient0_2%3a4.3.11+dfsg-0ubuntu0.16.04.11_amd64.deb /var/cache/apt/archives/libsmbclient_2%3a4.3.11+dfsg-0ubuntu0.16.04.11_amd64.deb /var/cache/apt/archives/samba-common_2%3a4.3.11+dfsg-0ubuntu0.16.04.11_all.deb /var/cache/apt/archives/tzdata_2017c-0ubuntu0.16.04_all.deb /var/cache/apt/archives/libisc-export160_1%3a9.10.3.dfsg.P4-8ubuntu1.8_amd64.deb /var/cache/apt/archives/libdns-export162_1%3a9.10.3.dfsg.P4-8ubuntu1.8_amd64.deb /var/cache/apt/archives/libidn11_1.32-3ubuntu1.2_amd64.deb /var/cache/apt/archives/libidn11_1.32-3ubuntu1.2_i386.deb /var/cache/apt/archives/libssl-doc_1.0.2g-1ubuntu4.9_all.deb /var/cache/apt/archives/libssl-dev_1.0.2g-1ubuntu4.9_amd64.deb /var/cache/apt/archives/libssl1.0.0_1.0.2g-1ubuntu4.9_i386.deb /var/cache/apt/archives/libssl1.0.0_1.0.2g-1ubuntu4.9_amd64.deb /var/cache/apt/archives/libicu55_55.1-7ubuntu0.3_i386.deb /var/cache/apt/archives/libicu55_55.1-7ubuntu0.3_amd64.deb /var/cache/apt/archives/libxml2_2.9.3+dfsg1-1ubuntu0.3_amd64.deb /var/cache/apt/archives/libxml2_2.9.3+dfsg1-1ubuntu0.3_i386.deb /var/cache/apt/archives/bind9-host_1%3a9.10.3.dfsg.P4-8ubuntu1.8_amd64.deb /var/cache/apt/archives/dnsutils_1%3a9.10.3.dfsg.P4-8ubuntu1.8_amd64.deb /var/cache/apt/archives/libisc160_1%3a9.10.3.dfsg.P4-8ubuntu1.8_amd64.deb /var/cache/apt/archives/libdns162_1%3a9.10.3.dfsg.P4-8ubuntu1.8_amd64.deb /var/cache/apt/archives/libisccc140_1%3a9.10.3.dfsg.P4-8ubuntu1.8_amd64.deb /var/cache/apt/archives/libisccfg140_1%3a9.10.3.dfsg.P4-8ubuntu1.8_amd64.deb /var/cache/apt/archives/liblwres141_1%3a9.10.3.dfsg.P4-8ubuntu1.8_amd64.deb /var/cache/apt/archives/libbind9-140_1%3a9.10.3.dfsg.P4-8ubuntu1.8_amd64.deb /var/cache/apt/archives/openssl_1.0.2g-1ubuntu4.9_amd64.deb /var/cache/apt/archives/ca-certificates_20170717~16.04.1_all.deb /var/cache/apt/archives/libcurl3-gnutls_7.47.0-1ubuntu2.4_amd64.deb /var/cache/apt/archives/tcpdump_4.9.2-0ubuntu0.16.04.1_amd64.deb /var/cache/apt/archives/wget_1.17.1-1ubuntu1.3_amd64.deb /var/cache/apt/archives/python3-problem-report_2.20.1-0ubuntu2.12_all.deb /var/cache/apt/archives/python3-apport_2.20.1-0ubuntu2.12_all.deb /var/cache/apt/archives/apport_2.20.1-0ubuntu2.12_all.deb /var/cache/apt/archives/apport-gtk_2.20.1-0ubuntu2.12_all.deb /var/cache/apt/archives/python-problem-report_2.20.1-0ubuntu2.12_all.deb /var/cache/apt/archives/python-apport_2.20.1-0ubuntu2.12_all.deb /var/cache/apt/archives/apport-retrace_2.20.1-0ubuntu2.12_all.deb /var/cache/apt/archives/bluez_5.37-0ubuntu5.1_amd64.deb /var/cache/apt/archives/bluez-cups_5.37-0ubuntu5.1_amd64.deb /var/cache/apt/archives/bluez-obexd_5.37-0ubuntu5.1_amd64.deb /var/cache/apt/archives/dnsmasq-base_2.75-1ubuntu0.16.04.3_amd64.deb /var/cache/apt/archives/libgdk-pixbuf2.0-0_2.32.2-1ubuntu1.3_amd64.deb /var/cache/apt/archives/libgdk-pixbuf2.0-common_2.32.2-1ubuntu1.3_all.deb /var/cache/apt/archives/firefox_57.0+build4-0ubuntu0.16.04.5_amd64.deb /var/cache/apt/archives/firefox-locale-en_57.0+build4-0ubuntu0.16.04.5_amd64.deb /var/cache/apt/archives/libnss3-nssdb_2%3a3.28.4-0ubuntu0.16.04.3_all.deb /var/cache/apt/archives/libnss3-1d_2%3a3.28.4-0ubuntu0.16.04.3_amd64.deb /var/cache/apt/archives/libnss3_2%3a3.28.4-0ubuntu0.16.04.3_amd64.deb /var/cache/apt/archives/libcurl3_7.47.0-1ubuntu2.4_amd64.deb /var/cache/apt/archives/flashplugin-installer_27.0.0.187ubuntu0.16.04.1_amd64.deb /var/cache/apt/archives/ghostscript_9.18~dfsg~0-0ubuntu2.7_amd64.deb /var/cache/apt/archives/ghostscript-x_9.18~dfsg~0-0ubuntu2.7_amd64.deb /var/cache/apt/archives/libgs9-common_9.18~dfsg~0-0ubuntu2.7_all.deb /var/cache/apt/archives/libgs9_9.18~dfsg~0-0ubuntu2.7_amd64.deb /var/cache/apt/archives/gir1.2-gdkpixbuf-2.0_2.32.2-1ubuntu1.3_amd64.deb /var/cache/apt/archives/libwebkit2gtk-4.0-37-gtk2_2.18.3-0ubuntu0.16.04.1_amd64.deb /var/cache/apt/archives/libwebkit2gtk-4.0-37_2.18.3-0ubuntu0.16.04.1_amd64.deb /var/cache/apt/archives/libjavascriptcoregtk-4.0-18_2.18.3-0ubuntu0.16.04.1_amd64.deb /var/cache/apt/archives/libwayland-client0_1.12.0-1~ubuntu16.04.2_amd64.deb /var/cache/apt/archives/libwayland-server0_1.12.0-1~ubuntu16.04.2_amd64.deb /var/cache/apt/archives/gir1.2-webkit2-4.0_2.18.3-0ubuntu0.16.04.1_amd64.deb /var/cache/apt/archives/gir1.2-javascriptcoregtk-4.0_2.18.3-0ubuntu0.16.04.1_amd64.deb /var/cache/apt/archives/git-man_1%3a2.7.4-0ubuntu1.3_all.deb /var/cache/apt/archives/git_1%3a2.7.4-0ubuntu1.3_amd64.deb /var/cache/apt/archives/libbluetooth3_5.37-0ubuntu5.1_amd64.deb /var/cache/apt/archives/libgd3_2.1.1-4ubuntu0.16.04.8_amd64.deb /var/cache/apt/archives/libgd3_2.1.1-4ubuntu0.16.04.8_i386.deb /var/cache/apt/archives/libgraphite2-3_1.3.10-0ubuntu0.16.04.1_amd64.deb /var/cache/apt/archives/libmircore1_0.26.3+16.04.20170605-0ubuntu1.1_amd64.deb /var/cache/apt/archives/libmircommon7_0.26.3+16.04.20170605-0ubuntu1.1_amd64.deb /var/cache/apt/archives/libmirprotobuf3_0.26.3+16.04.20170605-0ubuntu1.1_amd64.deb /var/cache/apt/archives/libmirclient9_0.26.3+16.04.20170605-0ubuntu1.1_amd64.deb /var/cache/apt/archives/mysql-common_5.7.20-0ubuntu0.16.04.1_all.deb /var/cache/apt/archives/libmysqlclient20_5.7.20-0ubuntu0.16.04.1_i386.deb /var/cache/apt/archives/libplist3_1.12-3.1ubuntu0.16.04.1_amd64.deb /var/cache/apt/archives/libpoppler58_0.41.0-0ubuntu1.5_amd64.deb /var/cache/apt/archives/libpoppler-glib8_0.41.0-0ubuntu1.5_amd64.deb /var/cache/apt/archives/libwayland-cursor0_1.12.0-1~ubuntu16.04.2_amd64.deb /var/cache/apt/archives/libxfont1_1%3a1.5.1-1ubuntu0.16.04.3_amd64.deb /var/cache/apt/archives/libxml2-utils_2.9.3+dfsg1-1ubuntu0.3_amd64.deb /var/cache/apt/archives/linux-firmware_1.157.13_all.deb /var/cache/apt/archives/linux-image-4.4.0-98-generic_4.4.0-98.121_amd64.deb /var/cache/apt/archives/linux-image-extra-4.4.0-98-generic_4.4.0-98.121_amd64.deb /var/cache/apt/archives/linux-generic_4.4.0.98.103_amd64.deb /var/cache/apt/archives/linux-image-generic_4.4.0.98.103_amd64.deb /var/cache/apt/archives/linux-signed-image-4.4.0-98-generic_4.4.0-98.121_amd64.deb /var/cache/apt/archives/linux-signed-generic_4.4.0.98.103_amd64.deb /var/cache/apt/archives/linux-signed-image-generic_4.4.0.98.103_amd64.deb /var/cache/apt/archives/linux-headers-4.4.0-98_4.4.0-98.121_all.deb /var/cache/apt/archives/linux-headers-4.4.0-98-generic_4.4.0-98.121_amd64.deb /var/cache/apt/archives/linux-headers-generic_4.4.0.98.103_amd64.deb /var/cache/apt/archives/linux-libc-dev_4.4.0-98.121_amd64.deb /var/cache/apt/archives/poppler-utils_0.41.0-0ubuntu1.5_amd64.deb /var/cache/apt/archives/python-jwt_1.3.0-1ubuntu0.1_all.deb /var/cache/apt/archives/python-libxml2_2.9.3+dfsg1-1ubuntu0.3_amd64.deb /var/cache/apt/archives/python3-jwt_1.3.0-1ubuntu0.1_all.deb /var/cache/apt/archives/qemu-user-static_1%3a2.5+dfsg-5ubuntu10.16_amd64.deb /var/cache/apt/archives/texlive-fonts-recommended_2015.20160320-1ubuntu0.1_all.deb /var/cache/apt/archives/texlive-latex-base_2015.20160320-1ubuntu0.1_all.deb /var/cache/apt/archives/texlive-latex-recommended_2015.20160320-1ubuntu0.1_all.deb /var/cache/apt/archives/texlive-generic-recommended_2015.20160320-1ubuntu0.1_all.deb /var/cache/apt/archives/texlive-base_2015.20160320-1ubuntu0.1_all.deb /var/cache/apt/archives/thunderbird-locale-en_1%3a52.4.0+build1-0ubuntu0.16.04.2_amd64.deb /var/cache/apt/archives/thunderbird_1%3a52.4.0+build1-0ubuntu0.16.04.2_amd64.deb /var/cache/apt/archives/thunderbird-gnome-support_1%3a52.4.0+build1-0ubuntu0.16.04.2_amd64.deb /var/cache/apt/archives/thunderbird-locale-en-gb_1%3a52.4.0+build1-0ubuntu0.16.04.2_all.deb /var/cache/apt/archives/thunderbird-locale-en-us_1%3a52.4.0+build1-0ubuntu0.16.04.2_all.deb /var/cache/apt/archives/wpasupplicant_2.4-0ubuntu6.2_amd64.deb /var/cache/apt/archives/xserver-common_2%3a1.18.4-0ubuntu0.7_all.deb /var/cache/apt/archives/xserver-xorg-core_2%3a1.18.4-0ubuntu0.7_amd64.deb /var/cache/apt/archives/xul-ext-ubufox_3.4-0ubuntu0.16.04.2_all.deb /var/cache/apt/archives/liblouis-data_2.6.4-2ubuntu0.1_all.deb /var/cache/apt/archives/liblouis9_2.6.4-2ubuntu0.1_amd64.deb /var/cache/apt/archives/python3-louis_2.6.4-2ubuntu0.1_all.deb 
/usr/bin/dpkg --status-fd 15 --configure perl-modules-5.22:all libperl5.22:amd64 perl:amd64 libwbclient0:amd64 samba-libs:amd64 samba-dsdb-modules:amd64 samba-common:all python-samba:amd64 samba-common-bin:amd64 samba:amd64 winbind:amd64 libnss-winbind:amd64 libpam-winbind:amd64 libsmbclient:amd64 smbclient:amd64 samba-vfs-modules:amd64 tzdata:all libisc-export160:amd64 libdns-export162:amd64 libidn11:i386 libidn11:amd64 libssl-doc:all libssl1.0.0:amd64 libssl1.0.0:i386 libssl-dev:amd64 libicu55:amd64 libicu55:i386 libxml2:i386 libxml2:amd64 libisc160:amd64 libdns162:amd64 libisccc140:amd64 libisccfg140:amd64 libbind9-140:amd64 liblwres141:amd64 bind9-host:amd64 dnsutils:amd64 openssl:amd64 ca-certificates:all libcurl3-gnutls:amd64 tcpdump:amd64 wget:amd64 python3-problem-report:all python3-apport:all apport:all apport-gtk:all python-problem-report:all python-apport:all apport-retrace:all bluez:amd64 bluez-cups:amd64 bluez-obexd:amd64 dnsmasq-base:amd64 libgdk-pixbuf2.0-common:all libgdk-pixbuf2.0-0:amd64 firefox:amd64 firefox-locale-en:amd64 libnss3-nssdb:all libnss3:amd64 libnss3-1d:amd64 libcurl3:amd64 flashplugin-installer:amd64 libgs9-common:all libgs9:amd64 ghostscript:amd64 ghostscript-x:amd64 gir1.2-gdkpixbuf-2.0:amd64 libjavascriptcoregtk-4.0-18:amd64 libwayland-client0:amd64 libwayland-server0:amd64 libwebkit2gtk-4.0-37:amd64 libwebkit2gtk-4.0-37-gtk2:amd64 gir1.2-javascriptcoregtk-4.0:amd64 gir1.2-webkit2-4.0:amd64 git-man:all git:amd64 libbluetooth3:amd64 libgd3:i386 libgd3:amd64 libgraphite2-3:amd64 libmircore1:amd64 libmircommon7:amd64 libmirprotobuf3:amd64 libmirclient9:amd64 mysql-common:all libmysqlclient20:i386 libplist3:amd64 libpoppler58:amd64 libpoppler-glib8:amd64 libwayland-cursor0:amd64 libxfont1:amd64 libxml2-utils:amd64 linux-firmware:all linux-image-4.4.0-98-generic:amd64 linux-image-extra-4.4.0-98-generic:amd64 linux-image-generic:amd64 linux-headers-4.4.0-98:all linux-headers-4.4.0-98-generic:amd64 linux-headers-generic:amd64 linux-generic:amd64 linux-signed-image-4.4.0-98-generic:amd64 linux-signed-image-generic:amd64 linux-signed-generic:amd64 linux-libc-dev:amd64 poppler-utils:amd64 python-jwt:all python-libxml2:amd64 python3-jwt:all qemu-user-static:amd64 texlive-base:all texlive-fonts-recommended:all texlive-latex-base:all texlive-latex-recommended:all texlive-generic-recommended:all thunderbird:amd64 thunderbird-locale-en:amd64 thunderbird-gnome-support:amd64 thunderbird-locale-en-gb:all thunderbird-locale-en-us:all wpasupplicant:amd64 xserver-common:all xserver-xorg-core:amd64 xul-ext-ubufox:all liblouis-data:all liblouis9:amd64 python3-louis:all 
/usr/bin/dpkg --status-fd 17 --configure --pending 

And yes, unattended-upgrades are enabled in the configuration:

10periodic :

APT::Periodic::Update-Package-Lists "1";
APT::Periodic::Download-Upgradeable-Packages "0";
APT::Periodic::AutocleanInterval "0";

20auto-upgrades :

APT::Periodic::Update-Package-Lists "1";
APT::Periodic::Unattended-Upgrade "1";

So why is unattended-upgrades not installing any upgrades?


Requested extras:

ls -l /var/lib/apt/periodic:

-rw-r--r-- 1 root root 0 Nov 16 18:49 download-upgradeable-stamp
-rw-r--r-- 1 root root 0 Nov 17 12:50 unattended-upgrades-stamp
-rw-r--r-- 1 root root 0 Nov 16 18:47 update-stamp
-rw-r--r-- 1 root root 0 Nov 17 12:19 update-success-stamp
-rw-r--r-- 1 root root 0 Oct  3 11:18 upgrade-stamp

This is the entireity of /var/log/unattended-upgrades-dpkg.log:

Log started: 2017-11-17  12:10:41
Log ended: 2017-11-17  12:10:42

Log started: 2017-11-17  12:25:57
Log ended: 2017-11-17  12:25:58

Log started: 2017-11-17  12:50:53
Log ended: 2017-11-17  12:50:54

All three of those entries are from me running "sudo unattended-upgrades --dry-run" manually.

The previous unattended-upgrades-dpkg.log.1.gz contains this:

Log started: 2017-10-03  11:18:26
^MExtract templates from packages: 36%^MExtract templates from packages: 72%^MExtract templates from packages: 100%
Preconfiguring packages ...
dpkg: error: dpkg status database is locked by another process
Log ended: 2017-10-03  11:18:27

Note that this computer gets rebooted every day. Previous log unattended-upgrades-dpkg.log.2.gz is quite long and actually shows stuff being installed. It ends with this:

Found linux image: /boot/vmlinuz-3.11.0-23-generic
Found initrd image: /boot/initrd.img-3.11.0-23-generic
Adding boot menu entry for EFI firmware configuration
done
Setting up linux-signed-image-generic (4.4.0.92.97) ...
Setting up linux-signed-generic (4.4.0.92.97) ...
Setting up linux-libc-dev:amd64 (4.4.0-92.115) ...
Setting up xul-ext-ubufox (3.4-0ubuntu0.16.04.1) ...
Processing triggers for libc-bin (2.23-0ubuntu9) ...
Log ended: 2017-08-21  10:29:14
  • 1
    Because download upgradable packages is set to 0? – Organic Marble Nov 17 '17 at 13:09
  • Please add ls -l /var/lib/apt/periodic and one relevant day from /var/log/unattended-upgrades/unattended-upgrades-dpkg.log showing upgrades were available but uninstalled. – user535733 Nov 17 '17 at 13:17
  • @OrganicMarble I don't think that is it, because nobody has ever touched the config afaik, and it used to work in the past. – Alistair Buxton Nov 17 '17 at 14:00
0

As Organic Marble pointed out, the likely culprit is the line

APT::Periodic::Download-Upgradeable-Packages "0";

in your configuration.

Per the Debian wiki, leaving that value set to zero disables the fetching of upgradeable packages:

// Do "apt-get upgrade --download-only" every n-days (0=disable)
APT::Periodic::Download-Upgradeable-Packages "1";

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.