After struggling to install NVIDIA drivers using the discrete graphics card, I finally recognized that my display backlight is always at full intensity and can not be changed via keyboard controls.

About my system

% sudo apt list --installed | grep nvidia
nvidia-387/artful,now 387.22-0ubuntu0~gpu17.10.2 amd64 [installed]
nvidia-opencl-icd-387/artful,now 387.22-0ubuntu0~gpu17.10.2 amd64 [installed,automatic]
nvidia-prime/artful,now 0.8.5 amd64 [installed,automatic]
nvidia-settings/artful,now 387.22-0ubuntu0~gpu17.10.1 amd64 [installed,automatic]

% ls /sys/class/backlight  # empty!

% ls /proc/acpi/ibm/                    
beep  bluetooth  cmos  driver  fan  hotkey  kbdlight  led  light  volume
% cat /proc/acpi/ibm/light
status:     off
commands:   on, off

% journalctl -b | grep backlight
Nov 17 10:46:10 P51 systemd[1]: Created slice system-systemd\x2dbacklight.slice.
Nov 17 10:46:10 P51 systemd[1]: Starting Load/Save Screen Backlight Brightness of leds:tpacpi::kbd_backlight...
Nov 17 10:46:10 P51 systemd[1]: Started Load/Save Screen Backlight Brightness of leds:tpacpi::kbd_backlight.
Nov 17 10:46:22 P51 gsd-media-keys[1489]: Failed to set new screen percentage: GDBus.Error:org.gtk.GDBus.UnmappedGError.Quark._gsd_5fpower_5fmanager_5ferror.Code0: Screen backlight not available

% journalctl | grep ACPI
Nov 17 10:46:10 P51 kernel: ACPI Error: [\_SB_.PCI0.XHC_.RHUB.HS11] Namespace lookup failure, AE_NOT_FOUND (20170531/dswload-210)
Nov 17 10:46:10 P51 kernel: ACPI Exception: AE_NOT_FOUND, During name lookup/catalog (20170531/psobject-252)
Nov 17 10:46:10 P51 kernel: ACPI Exception: AE_NOT_FOUND, (SSDT:ProjSsdt) while loading table (20170531/tbxfload-228)
Nov 17 10:46:10 P51 kernel: ACPI Error: 1 table load failures, 11 successful (20170531/tbxfload-246)

What I tried

  • I tried to modify GRUB_CMDLINE_LINUX_DEFAULT in /etc/default/grub (followed by update-grub2 and reboot) using always one of the following settings:

    acpi_backlight=vendor # thinkpad_acpi.brightness...
  • I created /usr/share/X11/xorg.conf.d/10-nvidia-brightness.conf:

    Section "Device"
        Identifier     "Device0"
        Driver         "nvidia"
        VendorName     "NVIDIA Corporation"
        BoardName      "Quadro M1200"
        Option         "RegistryDwords" "EnableBrightnessControl=1"

None of the above methods did yield any results worth mentioning.

  • Pretty much the identical issue. Ubuntu 17.10, on a Thinkpad P51. No solution yet but I've independently tried everything you've tried with one extra item. Adding this to grub instead: GRUB_CMDLINE_LINUX_DEFAULT="acpi_osi=Linux" Will cause the backlight prompt to react and seems to be "trying" but it seems to be incrementing/decrementing either by nothing or by too much? – samsquanch Jan 2 '18 at 23:50
  • Bug report filed: bugs.launchpad.net/ubuntu/+bug/1747273 – Michael Hoff Feb 4 '18 at 15:58

I found a workaround that work with my HP Zbook 15 with a nvidia quadro K610M. But none of the UI or hotkeys work. I always have to use a terminal...

My solution was to set the acpi_backlight to none in the grub config (/etc/default/grub): GRUB_CMDLINE_LINUX_DEFAULT="quiet splash acpi_backlight=none"

Then I use the xbacklight command (just add it with apt-get install xbacklight) http://manpages.ubuntu.com/manpages/xenial/man1/xbacklight.1.html

For instance for 50% of brightness I can type xbacklight =50.

Source: https://askubuntu.com/a/937133/783249

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.