0

Gitlab installation worked straight away but "they" want this server to also serve other webpages (wiki and other stuff) so I had to unbundle nginx from Gitlab and do a full installation.

From what I've seen here (https://www.linode.com/docs/development/version-control/how-to-unbundle-nginx-from-omnibus-gitlab-for-serving-multiple-websites) I need passenger installed but, oh surprise, look what happens if you try to:

apt-get install nginx-common
{..}
The following packages have unmet dependencies:
libnginx-mod-http-passenger : Depends: nginx-common (= 1.10.3-1ubuntu3.1) but 1.12.1-0ubuntu2 is to be installed
E: Unable to correct problems, you have held broken packages.

So basically it doesn't finish passenger installation and I cannot continue :S

Any brilliant ideas?

0

So, if anyone gets there:

sudo apt-get install nginx-extras
sudo apt-get install nginx-common 
sudo apt-get install passenger

And there you go. Hope it helps.

Your Answer

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.