0

How do I compile opus-tools to use Opus 1.2.1?

I've manually installed the latest version of Opus

wget https://archive.mozilla.org/pub/opus/opus-1.2.1.tar.gz
tar -xzf opus-1.2.1.tar.gz
cd opus-1.2.1
./configure
make
sudo make install

That completes without error and, I assume, means the 1.2.1 library is now installed.

I then try to compile opus tools:

wget https://archive.mozilla.org/pub/opus/opus-tools-0.1.10.tar.gz 
tar -xzf opus-tools-0.1.10.tar.gz
cd opus-tools-0.1.10
./configure
make

I now have opusenc and the other tools compiled in that directory. However, when I run ./opusenc --version I see

opusenc opus-tools 0.1.10 (using libopus 1.1.2)

What magic command to I need to use in order to get opusenc compiled with 1.2.1?

0

Uninstall the package libopus-dev; you don't need it since you want to compile using your own libopus.

4
  • I don't have it installed. I tried to apt-get remove libopus-dev and got Package 'libopus-dev' is not installed, so not removed Nov 17 '17 at 10:28
  • That is very weird; where is this 1.1.2 version coming from, then? What does ldd ./opusenc say?
    – fkraiem
    Nov 17 '17 at 11:03
  • 1
    I gave up and installed the Debian version of libopusdev. Sorry! Nov 17 '17 at 11:07
  • Then please delete your question if it is no longer relevant.
    – fkraiem
    Nov 17 '17 at 11:08
0

Your mistake was that after installing opus you didn't run sudo ldconfig

If you had then it would have linked to that version of opus you built & installed.( at runtime..

Note that the next time you installed any package that runs ldconfig the version you installed to /usr/local/ would then be used for better or worse..

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.