9

There is a package (python-pygame) for Python2 available from the universe repository. However, I want to work through the tutorial in the Invent with Python book. Going through SPM (Synaptic), I cannot find a pygame resource for Python3.

Also, I looked on the Pygame website and it is not clear if Pygame is available for Python3 (though the book indicates that it is).

Can someone help me with my dilemma?

2
  • IMPORTANT_MOVED.txt seems... important. So I changed the svn... line to hg clone https://bitbucket.org/pygame/pygame Jan 26 '12 at 22:30
  • Try this answer on Stack Overflow. It worked perfectly for me (minus the part where I forgot to copy and paste the apt-get command with the dependencies and had to hunt down and install them by hand).
    – fouric
    Oct 28 '13 at 5:08
6

From Pygame wiki:

Does Pygame work with Python 3?

Yes. Pygame 1.9.2 supports Python 3.2 and up. Only the orphaned _movie module (not built by default) does not.

However, there seems no pre-packaged Pygame packages for Python 3 in Ubuntu repositories, at least as of 14.04.

I would suggest you to get the source packages from the pygame website and install it locally into a virtualenv or buildout. Globally installing python modules in evil anyway :) Here are the instructions: http://www.pygame.org/wiki/CompileUbuntu

Alternatively you can try this PPA: https://launchpad.net/~thopiekar/+archive/ubuntu/pygame

5
  • Thanks for the suggestion! I have posted the steps in the original question for an explicit answer.
    – TheGeeko61
    Jan 23 '12 at 1:27
  • @TheGeeko61: I think you should post that as an answer, it's not "bad" in any way. Jan 26 '12 at 22:27
  • Alright, I'm doing so...
    – TheGeeko61
    Jan 27 '12 at 23:12
  • No longer up to date
    – Jonathan
    Jul 4 '15 at 20:53
  • @JonathanLeaders: It wasn't THAT much out of date: there are still no pre-compiled packages and you still have to install from source. I've added a few links to the answer though.
    – Sergey
    Jul 5 '15 at 1:06
5

Thanks to Sergey's suggestion, this is how to get it working:
INSTALL
(1) Move to a directory where you want the source code to be downloaded to
(2) svn co svn://seul.org/svn/pygame/trunk pygame
    NOTE:  Be sure to use the svn method.  Simply downloading the pygame*.tar.gz
           file from the pygame downloads page didn't work!
(3) cd pygame
(4) python3 config.py
    NOTE:  This confirms that you have the dependencies.
(5) python3 setup.py build
(6) sudo python3 setup.py install
    NOTE:  On my machine, I have the distro's python3.2 installed (which is in
           the /usr/lib directory).  This step places the pygame module into
           /usr/local/lib -- which is what you want (per Sergey's suggestion).

TEST
(1) python3
(2) At the '>>>' prompt, type "import pygame"
    VALIDATION:  If you get another '>>>' prompt, all is well.

per BlaXpirit, you may also choose to use hg instead of svn:

hg clone https://bitbucket.org/pygame/pygame

2

Someone needs to make a python3-pygame package that does this, but no one has yet

sudo apt-get install mercurial python3-dev python3-numpy libav-tools \
    libsdl-image1.2-dev libsdl-mixer1.2-dev libsdl-ttf2.0-dev libsmpeg-dev \
    libsdl1.2-dev  libportmidi-dev libswscale-dev libavformat-dev libavcodec-dev
hg clone https://bitbucket.org/pygame/pygame
cd pygame
python3 setup.py build
sudo python3 setup.py install
1
  • On 18.04 I had to replace libav-tools with ffmpeg but that did the trick.
    – Whippy
    Oct 6 '20 at 0:56
1

Just use the below command to install pygame for Python3.

pip3 install pygame

It could install pygame correctly on Ubuntu 16.04 and Python Python 3.5.2.

0

Thanks again to everyone.

Just did a clean install of Mint 18 Cinnamon 64bit, and was following TheGeek61's post above to get Pygame working again.

But when I tried python3 setup.py build came up with an error:

Traceback (most recent call last):
  File "setup.py", line 109, in <module>
    from setuptools import setup, find_packages
ImportError: No module named 'setuptools'

After some searching, ran the following:

sudo pip install -U setuptools

Which then allowed Pygame for Python3 to install successfully.

0

The pre-requisite packages right now on the Mavproxy wiki will not work with Raspbian :

sudo apt-get install python3-dev python3-opencv python3-wxgtk3.0 python3-pip python3-matplotlib python3-pygame python3-lxml python3-yaml

Instead you will need to use the old one :

sudo apt-get install python-dev python-opencv python-wxgtk3.0 python-pip python-matplotlib python-pygame python-lxml python-yaml

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.