I installed ubuntu on my old HP. it is the 11.10 version. I cannot find out how to connect it to my wireless network. I can't even get it to scan for available networks.

Link to my pastebin: http://pastebin.com/ZJS9y6Vq


OK, I will try to keep the terminal to a minimum because you are new to linux, but trust me it is a wonderful tool once you get used to it.

First we need to determine if Ubuntu 'sees' your wireless card. This is kind of like drivers in windows, except they are called kernel modules. Open a terminal (either by the unity menu or by pressing CTRL+ALT+T) and type this:

username@computer:~$ sudo lspci -v
[sudo] password for username: <type your password here>

Then copy all the output and paste it to a pastebin so that we can see if the correct kernel module is being used.

If it turns out to be the wrong one, you will either need to check out which one to insert (insmod) or check out a tool to 'wrap' the windows driver into a linux compatible version (ndiswrapper).

  • i managed to do everything until i had to type my password, it wont let me type anything after the colon on the second line. – ericagene Jan 23 '12 at 7:22
  • That's actually by design, you see you don't want people looking over your shoulder at your password. You also don't want it showing up in logs and such. Just type your password and hit enter, it will work :) – Huckle Jan 23 '12 at 14:53
  • ok thanks, it worked i pasted it to the pastebin, what should i do now? – ericagene Jan 23 '12 at 15:36
  • provide us the pastebin link, so we can see it. You can edit it into your original question so that when others read it they will have it right off the bat – Huckle Jan 24 '12 at 1:15
  • ok thank you really much :) what do you advise me to do? – ericagene Jan 24 '12 at 20:34

I have a Vostro 1000 with the same wireless card and I found that Ubuntu detects the card but does not install the correct drivers.

Use lspci command to display the details about hardware. It will display all of PCI connected hardware. Look the information for wireless card in the list, the match must be with this identifier [14e4:4312]. If the identifier is another you can try with Synaptic which I explain further.

$ sudo lspci -v
05:00.0 Network controller: Broadcom Corporation BCM4311 802.11a/b/g (rev 01) Subsystem: Dell Wireless 1490 Dual Band WLAN Mini-Card Flags: bus master, fast devsel, latency 0, IRQ 18 Memory at c0200000 (32-bit, non-prefetchable) [size=16K] Capabilities: [40] Power Management version 2 Capabilities: [58] MSI: Enable- Count=1/1 Maskable- 64bit- Capabilities: [d0] Express Legacy Endpoint, MSI 00 Capabilities: [100] Advanced Error Reporting Capabilities: [13c] Virtual Channel Kernel driver in use: b43-pci-bridge Kernel modules: ssb

$ sudo lspci -nn
05:00.0 Network controller [0280]: Broadcom Corporation BCM4311 802.11a/b/g [14e4:4312] (rev 01)

To solve the problem install the correct driver for this wireless card and remove the incorrect driver (bcmwl) which Ubuntu installed by default.

$ sudo apt-get update
$ sudo apt-get install firmware-b43-installer 
$ sudo apt-get remove bcmwl-kernel-source 
$ sudo reboot

And I had the wireless card working again! Because I upgraded the Ubuntu version and with the last it worked fine after installation.

Or if you prefer, it can be done with Synaptic by

  • getting the b43-fwcutter, firmware-b43-installer

  • uninstalling the bcmwl-kernel-source (installed by default)

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.