0

After swapping CPU and mobo, I've had a lot of trouble getting networking running again. I deleted all my original bonding configs from /etc/network/interfaces and uninstalled NetworkManager.

It's now working with a dedicated line fpr the host and three unique lines for three different vlans on which my vms are bridged.

ip links output still shows a bond0 interface. I was wondering whether you could help me locate where this is coming from.

I am on Ubuntu 16.04.

/etc/network/interfaces looks like this:

source /etc/network/interfaces.d/*
auto lo
iface lo inet loopback
Host interface internes Netzwerk

auto rename2
iface rename2 inet static
address 192.168.2.100
gateway 192.168.2.1
netmask 255.255.255.0
network 192.168.2.0
broadcast 192.168.2.255
dns-nameservers 192.168.2.100

auto eno1
iface eno1 inet manual
auto rename4
iface rename4 inet manual
auto rename5
iface rename5 inet manual

Can anybody help me to locate and kill bond0?

Also I would really appreciate it if I could rename the interfaces. I tried it via entries in /etc/systemd/network/

As an example I did this for the rename2 nic:

[Match]
MACAddress=00:25:90:f3:9c:ea

[Link]
Name=mgmti0

Which doesn't work.

Thank you!

Edit: Managed to get rid of bond0 just now. A simple
ip link delete bond0.
sufficed

Edit2: Well, one reboot later and an an interface has at the same time swapped names with another AND that one was renamed. Also bond0 is back again.

I think I'll pull a windows on this machine and just reinstall.

0

When the bonding module (kernel driver) loads, it creates by default a first interface with name bond0. You can just ignore this interface, it does no harm. You can also just delete it with ip link delete bond0. However, next time it will be back again. Indeed, you don't want the driver to create such an interface, because you can create any number of bond interfaces dynamically. When loading the module, you can pass an argument to the driver, not to create the interface, like rmmod bonding ; modprobe bonding max_bonds=0.

What you actually want to do is write a file /etc/modprobe.d/bonding.conf with

options bonding max_bonds=0

Your Answer

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.