I have a custom keyboard layout that I want to add to Ubuntu 17.10. This question relates to How do I install a keyboard layout? but unfortunate I'm not allowed to comment on that one. Basically I have done the same thing.

I have downloaded http://tlundqvist.org/sv_dvorak/drivers/se_sv_dvorak_new.xorg and saved it to /usr/share/X11/xkb/symbols/se_sv_dvorak

I have added below section to /usr/share/X11/xkb/rules/evdev.xml

<layout>
  <configItem>
    <name>se_sv_dvorak</name>

    <shortDescription>svd</shortDescription>
    <description>Swedish dvorak</description>
    <languageList>
      <iso639Id>swe</iso639Id>
    </languageList>
  </configItem>
</layout>

I have also added below section to /usr/share/X11/xkb/rules/evdev.lst

se_sv_dvorak     Swedish dvorak

Then I have:

  • sudo dpkg-reconfigure xkb-data
  • systemctl restart keyboard-setup

I have also tried to reboot but when I go to Settings -> Region & Language and press + I can't find my new layout. What is wrong?

EDIT 1: This is what I can select:

EDIT 2: By running sudo dpkg-reconfigure keyboard-configuration I can change to right keyboard layout but that only works until I have logged in.

  • 2
    The menu item should be present in a sub menu of Swedish (Sweden). – Gunnar Hjalmarsson Nov 16 '17 at 13:14
  • Yes it should but it is not. Have updated post with pictures. – Elias Näslund Nov 17 '17 at 6:09
  • 1
    I meant to say that you should click the Swedish (Sweden) option to open the sub menu. – Gunnar Hjalmarsson Nov 17 '17 at 7:22
  • Doh! Didn't know you could do that! Then it works like a charm. Thanks! – Elias Näslund Nov 17 '17 at 11:40

Your Answer

 

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Browse other questions tagged or ask your own question.