8

I've just upgraded to FF 57 and websites that use their own fonts have stopped displaying text.

I know this is a problem others have had, e.g. Firefox doesn't display website text, but the solutions there have not worked. Safe mode does not help either, the problem only goes away if I uncheck the custom fonts option in Preferences.

I have custom fonts installed as well (from TexLive and and a couple more) so I'm thinking that might be the cause.

Any ideas on how to troubleshoot this?

Example from Github:

github no text

  • Seems like TeXGyreHeros was the cuplprit, I installed it and Twitter and Github now work correctly. It's available in the fonts-texgyre package. No idea why the upgrade to 57 caused this. – Bar Nov 16 '17 at 10:09
  • Had to do the same with Youtube and fonts-roboto. Seems like many fonts are missing. – Bar Nov 16 '17 at 10:24
  • 1
    One website I've haven't been able to fix is (ironically) addons.mozilla.org which uses the Fira font family. I've installed those according to instructions, and for a while they seem to work, but revert back to no text shown. – Bar Nov 16 '17 at 12:26
  • In my case I had this problem in one computer but not in another with similar settings. None of the answers given here to date fix this. I have opened another post askubuntu.com/q/980681/446253 – XavierStuvw Nov 27 '17 at 11:13
8

This is a combination of a few things: TexLive is installing fonts in a not-so-standard location, and the webpage is requesting a font that Ubuntu's fontconfig package thinks is better fullfilled by one of the TexLive fonts rather than a normal font. Firefox is then told to use the TexLive font for rendering, but it's not allowed to reach it from inside its security sandbox.

The recommended workaround is to set

security.sandbox.content.read_path_whitelist to /usr/local/texlive/

in about:config, and restarting the browser.

This is fixed on a more fundamental level in Firefox 58 and later.

  • 1
    I should suggest a better solution: to set /usr/local/texlive/. In this way, we can avoid pointing to the year of TeXLive release – Domenico Cufalo Nov 18 '17 at 15:58
  • I’m a little unconvinced this is exactly what’s going on. I do have TexGyre fonts installed, but installed manually so, though some other package may have installed them in a special folder, they were installed in a standard one first. Also the sites I have problems with were using anodyne MS fonts that are installed in the system font locations. There is no need to substitute them and they are in folders that should be exceptions to Firefox’s new sandboxing. Also different users have problems with different sites. Anyhow, setting the sandboxing level to 2 works for me until this is fixed. – Moilleadóir Nov 20 '17 at 13:20
  • You should file a bug in Bugzilla with more details, or the issue won't get fixed. – gcp Nov 21 '17 at 13:41
  • I agree that /usr/local/texlive should be used to avoid the year. Other answer upvoted for this reason. – Ege Rubak Nov 23 '17 at 13:40
  • Edited, though the fix has been uplifted to Firefox 58 now, so by 2018 this workaround will no longer be needed. – gcp Nov 23 '17 at 17:16
3

I too installed fonts-texgyre in my Debian 9 Stretch and the visualization of web pages has improved, but there are still some issues. Maybe we should install each font available in repositories, but it's clear that such a solution is not practical.

The only real solution would be to disable /etc/fonts/conf.d/09-texlive.conf.

If someone find another solution, it is welcome!

  • What do you mean by disable here? What would be the effect on Firefox? – Bar Nov 16 '17 at 14:48
  • 1
    sudo mv /etc/fonts/conf.d/09-texlive.conf /etc/fonts/conf.d/09-texlive.conf.BAK and then sudo fc-cache -fsv – Domenico Cufalo Nov 16 '17 at 14:51
  • 2
    It seems that texlive fonts installed on a Linux System cause some conflict. – Domenico Cufalo Nov 16 '17 at 14:58
  • 1
    Unfortunately, this solution is not good as it makes texlive fonts useless to other applications – Domenico Cufalo Nov 16 '17 at 14:59
  • 1
    OK thanks. I'll accept this as answer since it does solve the problem. Sucks that we can't use texlive fonts, and I can't understand how FF 56 vs. 57 causes this though. – Bar Nov 16 '17 at 15:00
3

In about:config, set

security.sandbox.content.read_path_whitelist 

to

/usr/local/texlive/

Works after restarting Firefox.

2

Try to go to about:preferences > Language & Appearance > Advanced, and unset "Allow pages to choose their own fonts, instead of your selections above". This resolves the issue for me, although now all fonts are defaulted to DejaVu.

  • It's a workaround rather than a fix, works for me too though. – pbhj Nov 18 '17 at 22:12
1

Just found a better solution, without installing anything!

In Firefox address bar, go to about:config, then search for

security.sandbox.content.level

and set this string to 1. Restart Firefox and... :-D

Your Answer

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.