0

His guys it is well known that when mounting a file system, a number of options may be supplied, such as enabling read-only or read-write access to the data on the mounted file system. However I have a newly-created ext4 file system already mounted in my directory hierarchy. Currently, I am required to remount the already mounted file system, providing only read access to its contents.

I used the following command with the sdb1 already mounted to ext4 file system. Currently I am about to remount it to the Sales directory in a "read only" option.

When I entered the command line , the option of or read only didn't work. It remained in its default which was read and write (rw).

Can someone help me please.

  • 1
    Doesn't sudo mount -o remount,ro /dev/sdb1 work? – Terrance Nov 16 '17 at 3:29
  • 3
    It would be of some assistance to us, if you included the command that you tried to execute. – Charles Green Nov 16 '17 at 3:32
  • The comand I tried to execute is <sudo mount -t ext4 remount, ro /dev/sdb1 /Sales> – Runick Fru Al Nov 17 '17 at 2:05

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.