The issue I'm having is pretty straightforward: I'll place windows in specific workspaces. Then if the screen happens to turn off and lock (it doesn't fully go to sleep), when I unlock the screen windows will change workspaces.

What usually happens is that windows in the right two workspaces will move to the same position in the left workspaces. Though occasionally one particular window in the bottom right workspace (for Slack), will move to the top left workspace.

So, is there some way I can prevent this from happening so I don't have to go through setting up my workspaces again every time I walk away from my desk?

Some possibly relevant information:

  • I'm running Ubuntu 16.04 LTS
  • My system is a new Dell XPS 15 9560
  • I'm using the built-in Nvidia GeForce GTX 1050 GPU, not the Intel GPU
  • I'm using an external monitor (AOC U2879VF) via a Thunderbolt 3 dock with the built in screen disabled
  • The issue still occurs if I have the built-in screen enabled
  • The issue doesn't seem to occur if I'm only using the built-in screen
  • A similar thing occurs when I unplug the system from the dock, but when the screen locks there's no indication that the dock is disconnected (ethernet IO lights keep flashing, keyboard/mouse stay on, etc.)
  • By "occurs if I have the built-in screen enabled" do you mean that it is the primary, or is the external display still primary in that case? – dobey Nov 15 '17 at 20:39
  • @dobey yes it is the primary screen when I have it enabled and am using both screens. – Ian Nov 15 '17 at 20:45
  • Which kernel and Xorg versions are you using? Did you install from 16.04.3 ISO, or an earlier one? – dobey Nov 15 '17 at 20:51
  • 2
    OK. Just wanted to make sure you were on the HWE stack. This sounds like a bug that is unlikely to be answered on here, and should be reported. What happens is that when the external display turns off, it gets "removed" so all the windows get shuffled off, and so when the display comes back, they are on the wrong workspace. This is an issue somewhere in the stack with the DisplayPort MST handling (though I'm not sure where in the stack exactly). I too hit this issue once when trying to configure my 4K monitor a certain way, but presumed my issues were more complex so didn't report it then. – dobey Nov 15 '17 at 21:35
  • 1
    You can possibly connect the external display via HDMI instead of the Thunderbolt 3 connection, to work around this specific issue. – dobey Nov 15 '17 at 21:38

There is a four year old bug report on this and the fix is in and it's been triaged:

Windows change Monitor/Desktop after screen lock

In the short term instead of locking the screen on inactivity (which basically shuts it off with gnome-screensaver I think) you could consider a screen saver with password that kicks in after a period of inactivity. I haven't tested this myself mind you.

Your Answer

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.