Trying to install VeraCrypt on a new install og Kubuntu 17.10. However I'm having some trouble.

Running the veracrypt-1.21-setup-gui-x64 file (double click -> execute), extracted from archive (verified sha512 and GPG), produce this output in the terminal it opens:

Verifying archive integrity...  100%   All good.
Uncompressing VeraCrypt 1.21 Installer  100%  
Unknown option 'caption'.
Press Return to close this window...

Tried instead running the file in bash (from some article "how to install VC)

sudo bash veracrypt-1.21-setup-gui-x64 

Produced this:

-------------> ~/Downloads/veracrypt-1.21-setup 
USER - > sudo bash veracrypt-1.20-setup-gui-x64 
Verifying archive integrity...  100%   All good.
Uncompressing VeraCrypt 1.20 Installer  100%  
QStandardPaths: XDG_RUNTIME_DIR not set, defaulting to '/tmp/runtime-root'
QStandardPaths: XDG_RUNTIME_DIR not set, defaulting to '/tmp/runtime-root'
Unknown option 'caption'.

I also tried install veracrypt-1.20, if the fault was with 1.21, but no luck.

I have no idea what any of that means. On 17.04 I installed VC no problem.

Has it something to do with me installing Flatpak (for Steam)? XDG rings a bell as some "older" name for Flatpak, iirc.

Any ideas as to what's wrong here?

I found a Sourceforuge thread about the same issue, but no answers.

  • The thread you linked has a very interesting error message: wrong ownership on runtime directory /run/user/1000. Did you noticed something similar in your case and if so, have you been changing permissions and/or perhaps running graphical programs with root privileges (with sudo)?
    – user692175
    Nov 15, 2017 at 15:19
  • I didn't get any other output than what I posted. I have not changed any permissions, as far as I'm aware, nor am I running anything with root privileges. Only CLI trying to install, and Firefox and Spotify. Nov 15, 2017 at 15:31

1 Answer 1


I found the answer to the problem, while digging through the Discussions section of the veracrypt.codeplex.com page.

Thread with answer.

Short version: Install XTerm. VC setup need to open it.

The answer itself:

Thought I'd have another look, and I've figured it out. There's two solutions:

1) The Veracrypt installer tries to display an xterm window at the end showing file paths, followed by "press enter to exit". However, this is not installed by default in KDE Neon (unlike Kubuntu, etc). So just install xterm:

$ sudo apt-get install xterm


2) pkexec env XDG_RUNTIME_DIR=$XDG_RUNTIME_DIR /home//Downloads/veracrypt-1.19-setup-gui-x64

The latter installs Veracrypt without the pop up windows, and just uses text in the terminal.

Hope it helps someone else.

Posted by Nickk9, Dec 22, 2016 at 3:33 PM

Thank you, Nickk9! <3

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .