3

I want to compile keepassx 0.4. It says I need qmake. I enter apt-get install qmake and nothing happens.

Also I did

sudo apt-get install build-essential cmake qtbase5-dev libqt5x11extras5-dev qttools5-dev qttools5-dev-tools libgcrypt20-dev zlib1g-dev libxi-dev libxtst-dev

and also I run all commands from here

https://wiki.qt.io/Install_Qt_5_on_Ubuntu

Nothing help.

Everything I try gives me:

qmake: could not exec '/usr/lib/x86_64-linux-gnu/qt4/bin/qmake': No such file or directory
CMake Error at /usr/share/cmake-3.7/Modules/FindQt4.cmake:1318 (message):
  Found unsuitable Qt version "" from NOTFOUND, this code requires Qt 4.x
Call Stack (most recent call first):
  CMakeLists.txt:59 (FIND_PACKAGE)

Please help!

  • As noted by the error message, it requires Qt 4.x, not Qt 5. You need to install the qt4 development stack. – dobey Nov 15 '17 at 15:42
  • @dobey I copy\pasted a lot of words into the terminal that has qt4 in them. Will it work? How do I know what I have? – mevsme Nov 15 '17 at 16:44

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.