2

How to connect VPN using PPTP in Ubuntu 17.10?

I have provided the Options:

screenshot

System Error Log:

Nov 15 20:09:25 ST21IND1042 NetworkManager[13773]: [1510756765.9541] audit: op="connection-activate" uuid="85634108-6d10-4a5c-a0be-acc75f6c9c16" name="COMPANY" pid=15146 uid=1000 result="success"
Nov 15 20:09:25 ST21IND1042 NetworkManager[13773]: [1510756765.9599] vpn-connection[0x5598beb502c0,85634108-6d10-4a5c-a0be-acc75f6c9c16,"COMPANY",0]: Started the VPN service, PID 17223
Nov 15 20:09:25 ST21IND1042 NetworkManager[13773]: [1510756765.9709] vpn-connection[0x5598beb502c0,85634108-6d10-4a5c-a0be-acc75f6c9c16,"COMPANY",0]: Saw the service appear; activating connection
Nov 15 20:09:25 ST21IND1042 gnome-shell[1388]: Invalid VPN service type (cannot find authentication binary)
Nov 15 20:09:26 ST21IND1042 gnome-shell[1388]: Invalid VPN service type (cannot find authentication binary)
Nov 15 20:09:26 ST21IND1042 NetworkManager[13773]: [1510756766.0027] vpn-connection[0x5598beb502c0,85634108-6d10-4a5c-a0be-acc75f6c9c16,"COMPANY",0]: Failed to request VPN secrets #3: No agents were available for this request.
Nov 15 20:09:26 ST21IND1042 NetworkManager[13773]: [1510756766.0148] vpn-connection[0x5598beb502c0,85634108-6d10-4a5c-a0be-acc75f6c9c16,"COMPANY",0]: VPN plugin: state changed: stopped (6)

Please let me know, if anything i have missed it.

  • Do you have the network-manager-pptp-gnome package installed? – dobey Nov 15 '17 at 15:45
  • Yes. I have installed that package but no luck – venkat Nov 16 '17 at 7:04
2

I managed to solve the same issue like this:

$ ls /etc/NetworkManager/system-connections/

I compared my VPN configurations between my Ubuntu 17.10 and another machine with a different Linux (where the VPN did work) and changed the 17.10 configuration accordingly.

"[vpn]
password-flags=" was set to "1", I changed it to "0"

"[vpn-secrets]
password=" was completely missing, so I just added it after the "[vpn]"-section and filled out my password before saving the configuration.

Then I restarted the network manager:
$ sudo service network-manager restart

That's it.

  • Please use code markup, the {}on top of the editor. But I don't think your settings will solve OPs issue, which seems that network manager is unable to find a binary. – Robert Riedl Feb 4 '18 at 19:28
1

I am also having this problem, and was able to workaround by saving the username \ password in the VPN config. It seems that the real issue is the inability to bring up the password prompt, not the PPTP module itself.

This Arch thread lead me to the answer. Looks like some additional work with fixing symlinks is needed if you want the password prompt back, assuming this is pretty much the same problem.

https://bbs.archlinux.org/viewtopic.php?id=153763

  • I've been experiencing a similar issue. Has anyone filed this under a bug on launchpad? – Sarah Szabo Feb 4 '18 at 16:04
0

In Ubuntu 17.10 I managed to make it work editing the file whose name is the same as the VPN connection's name in directory /etc/NetworkManager/system-connections, where I changed the value of password-flags to 2, and after user I added a field password with my password.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.