0

I have made all steps from How to share files through the local network?

I am able to connect to my PC1, if it works as WIFI router with its built in WIFI adapter, but if I connect it to my WIFI router, it has internet.

My second PC2 are connected to the same WIFI router too and has internet.

I know IPs of both. I can not connect with sftp in both ways.

In first case it says: Oops! Something went wrong, Unhandled error message. Timed out when logging in.

The PC2 says: Unable to access location. No route to host

my PC1's IP: 192.168.0.101, and second IP 192.168.0.102

How to find out what's wrong. I am really tired of messing up with USB flash drive and copy/move files with it.

I've wasted an hour for this with no result.

Words that Ubuntu/Linux is user friendly are real bullshit.

  • Quite possible that firewall is blocking communication on port 21 for ftp. is the ftp service running on your machine? Install nmap and do a nmap localhost to check that. – Abel Tom Nov 15 '17 at 12:58
  • @AbelTom everything is open. – mevsme Nov 15 '17 at 14:00
  • Then, I would suggest do a sudo ufw enable and sudo ufw status to see ssh and ftp status on both the machines. ufw-Uncomplicated firewall. Would be nice if you could show the output. – Abel Tom Nov 15 '17 at 14:06
  • @AbelTom can something be with the router, that it doesn't allow me access computers? Or if both has internet, then both should be able connect each other? – mevsme Nov 15 '17 at 14:31
  • user@pc:~$ sudo ufw status verbose Status: active Logging: on (low) Default: deny (incoming), allow (outgoing), disabled (routed) New profiles: skip @AbelTom – mevsme Nov 15 '17 at 14:34
0

You need to tell your firewall that it should accept incoming connections from ssh and ftp. Try doing a sudo ufw allow ssh and sudo ufw allow ftp, and ask for status. (sudo ufw status)

  • didn't help. I don't think it's FW issue because I can connect PC1 with PC2 if PC1 is router and broadcasts WIFI connection. Maybe something with my external home router? Can it be so? Thanks for you tries to help. – mevsme Nov 15 '17 at 15:03

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.