1

firefox font problem screenshot

I already tried these:

  1. Enabling and disabling hardware acceleration.
  2. sudo apt-get install ttf-mscorefonts-installer culmus
  3. Unity Tweak Tool >Font> Hinting > Slight
  4. Changing the default fonts
  5. Checking :Allow pages to choose their own fonts, instead of your selections above
  6. sudo apt-get install msttcorefonts(it gives output:selecting 'ttf-mscorefonts-installer' instead of 'msttcorefonts')

This is the google chrome screenshot:

Google chrome Font looks much better

Also , in about:config > gfx.font .There is no option for gfx.font_rendering.cleartype_params.rendering_mode which was given a solution here

  • 1
    Have you checked in about:preferences and in Language and Appearance and in Advanced settings and checked that Allow pages to choose their own fonts, instead of your selections above is selected? – Terrance Nov 15 '17 at 4:34
  • @Terrance Yes It was already checked. – shaurya airi Nov 15 '17 at 5:14
  • Probably because you don't have the core fonts installed or maybe I'm wrong. Could you try the command sudo apt-get install msttcorefonts and re-open the FireFox and try. – AzkerM Nov 15 '17 at 5:44
  • @AzkerM on running the command I got this: Note, selecting 'ttf-mscorefonts-installer' instead of 'msttcorefonts' ttf-mscorefonts-installer is already the newest version. – shaurya airi Nov 15 '17 at 6:05
  • Is your issue that DIFFERENT fonts are being used in Firefox web pages compared to Chrome? For example, is Firefox using DejaVu, while chrome is using Arial? Or, is your issue that the font HINTING is not as nice in Firefox, compared to Chrome. For example, do fonts look fuzzy to you in Firefox but they look sharp in Chrome? – PJ Singh Nov 15 '17 at 15:54
3

Optional

If it exists, remove fonts.conf; fonts.conf is used by KDE applications, but Ubuntu uses gsettings instead. On Ubuntu, it is a good idea to remove this file, so it does not interfere with your font settings. In a terminal, execute the following.

rm ~/.config/fontconfig/fonts.conf

Select Hinting

Select one of the following options, depending on your font hinting preference.

  1. Full Hinting (Try this first, since I suspect it is what you will like most)

    If you want full hinting, execute the following in a terminal.

    sudo rm /etc/fonts/conf.d/10-hinting-*.conf
    sudo ln -sv /etc/fonts/conf.avail/10-hinting-full.conf /etc/fonts/conf.d/
    
  2. Medium Hinting

    If you want medium hinting, execute the following in a terminal.

    sudo rm /etc/fonts/conf.d/10-hinting-*.conf
    sudo ln -sv /etc/fonts/conf.avail/10-hinting-medium.conf /etc/fonts/conf.d/
    
  3. Slight Hinting

    To undo this change, or to use slight hinting (default), execute the following in a terminal.

    sudo rm /etc/fonts/conf.d/10-hinting-*.conf
    sudo ln -sv /etc/fonts/conf.avail/10-hinting-slight.conf /etc/fonts/conf.d/
    

Check Results

Reboot, since the above changes are global to your system. Launch Firefox and hopefully you will see sharper, clearer fonts. Also, note that the address / search bar in Firefox may still display slightly fuzzy fonts, and I have not found a way to change this. However, you should see a marked improvement in web pages.

  • This doesn't change anything with Firefox 64 and Ubuntu 18.04. Also there is no ~/.config/fontconfig so nothing to delete in the first (optional) step. – Sarge Borsch Dec 17 '18 at 9:50

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.