This question already has an answer here:

Occasionally my computer(Lubuntu 16.04 64 Bit) gets stuck at shutdown. It shows the message nmi watchdog bug soft lockup - cpu#1 stuck for 22s and never finishes shutdown.This message comes after the message Reached target shutdown.. What causes this error? How do I resolve this?

marked as duplicate by karel, Fabby, Zanna, Eric Carvalho, Thomas Nov 10 '18 at 15:18

This question has been asked before and already has an answer. If those answers do not fully address your question, please ask a new question.


I had the same bug on my machine, I fixed it by appending nouveau.modeset=0 to the grub command line

To do so, when you're in grub menu, press e to edit the command line. Then append nouveau.modeset=0 at the end of the line beginning with linux. Then press F10 to continue to boot, login into your user session, then try to reboot the computer to see if the problem is gone or if you still have the issue.

If the problem is gone, you can make the change permanent by editing the grub config.

sudo nano /etc/default/grub, append nouveau.modeset=0 in the quotes of the line GRUB_CMDLINE_LINUX_DEFAULT="...". Then update your grub setup with sudo update-grub.

Related to

NMI watchdog: BUG: soft lockup - CPU#2 stuck for 23s! [nvidia-smi:566]
  • Could you explain why this worked in your opinion? Or, if you found this on some source, what the source says in terms of explanation of why it works? – Kubuntuer82 May 30 '18 at 10:41

Not the answer you're looking for? Browse other questions tagged or ask your own question.