My Ubuntu machine has set my external HDD to read only. The drive is a 2TB That I have configured to fat32 so that almost everything can read/write to it. I know that from using the search box on this site one fix is "sudo nautilus." I went to my hdd in the file manager, right clicked , properties. under permissions i tell it to allow read/write, but it says it is a read only file system... I know from some googleing that there is a chance in a fix by unmounting the drive, then forcing it to mount. I heard that this causes a loss in data though, and the content on the drive is important (which is why i just don't reformat the drive). If it helps I just reinstalled Ubuntu, so i don't know if my old profile is the "owner of the drive" under the permissions tab because i made it the same user name...I know that if i go to a windows computer i can tell it to take ownership, where i can then disable read only. is there no way to do this from Ubuntu?

gnomes@gnomes:~$ mount
/dev/sda1 on / type ext4 (rw,errors=remount-ro,commit=0)
proc on /proc type proc (rw,noexec,nosuid,nodev)
sysfs on /sys type sysfs (rw,noexec,nosuid,nodev)
fusectl on /sys/fs/fuse/connections type fusectl (rw)
none on /sys/kernel/debug type debugfs (rw)
none on /sys/kernel/security type securityfs (rw)
udev on /dev type devtmpfs (rw,mode=0755)
devpts on /dev/pts type devpts (rw,noexec,nosuid,gid=5,mode=0620)
tmpfs on /run type tmpfs (rw,noexec,nosuid,size=10%,mode=0755)
none on /run/lock type tmpfs (rw,noexec,nosuid,nodev,size=5242880)
none on /run/shm type tmpfs (rw,nosuid,nodev)
binfmt_misc on /proc/sys/fs/binfmt_misc type binfmt_misc (rw,noexec,nosuid,nodev)
gvfs-fuse-daemon on /home/gnomes/.gvfs type fuse.gvfs-fuse-daemon (rw,nosuid,nodev,user=gnomes)
/dev/sdb1 on /media/THIRSTY 2TR_ type vfat (rw,nosuid,nodev,uid=1000,gid=1000,shortname=mixed,dmask=0077,utf8=1,showexec,flush,uhelper=udisks)
/home/gnomes/.Private on /home/gnomes type ecryptfs (ecryptfs_check_dev_ruid,ecryptfs_cipher=aes,ecryptfs_key_bytes=16,ecryptfs_unlink_sigs,ecryptfs_sig=40584e1d6fa2a33e,ecryptfs_fnek_sig=83ad2a5a52a1069e)


# /etc/fstab: static file system information.
# Use 'blkid' to print the universally unique identifier for a
# device; this may be used with UUID= as a more robust way to name devices
# that works even if disks are added and removed. See fstab(5).
# <file system> <mount point>   <type>  <options>       <dump>  <pass>
proc            /proc           proc    nodev,noexec,nosuid 0       0
# / was on /dev/sda1 during installation
UUID=839b800b-ce92-4d72-ad5b-0e84de7c74be /               ext4    errors=remount-ro 0       1
# swap was on /dev/sda5 during installation
#UUID=e25b3b92-d693-4c93-8e08-2470aa0f5152 none            swap    sw              0       0
/dev/mapper/cryptswap1 none swap sw 0 0

I just found this on a possible sister site to this one https://superuser.com/questions/105769/external-hard-drive-is-read-only-how-to-change-owner-ubuntu I want need to know if this is the solution since my drive is in fat 32 not nfts, and if this will wipe any data on my external

edit- the drive is posted Its name is "THIRSTY 2TR"

I tried sudo mount -o remount,rw '/media/THIRSTY 2TR' and it did nothing... it makes an arrow like ^ but facing right after

me messing around i got this, which looks promising, but means nothing to a noob like me

gnomes@gnomes:~$ sudo mount -o remount,rw '/media/THIRSTY 2TR'
[sudo] password for gnomes: 
gnomes@gnomes:~$ sudo mount -THIRSTY 2TR remount,rw '/media/THIRSTY 2TR'
mount: invalid option -- 'T'
Usage: mount -V                 : print version
       mount -h                 : print this help
       mount                    : list mounted filesystems
       mount -l                 : idem, including volume labels
So far the informational part. Next the mounting.
The command is `mount [-t fstype] something somewhere'.
Details found in /etc/fstab may be omitted.
       mount -a [-t|-O] ...     : mount all stuff from /etc/fstab
       mount device             : mount device at the known place
       mount directory          : mount known device here
       mount -t type dev dir    : ordinary mount command
Note that one does not really mount a device, one mounts
a filesystem (of the given type) found on the device.
One can also mount an already visible directory tree elsewhere:
       mount --bind olddir newdir
or move a subtree:
       mount --move olddir newdir
One can change the type of mount containing the directory dir:
       mount --make-shared dir
       mount --make-slave dir
       mount --make-private dir
       mount --make-unbindable dir
One can change the type of all the mounts in a mount subtree
containing the directory dir:
       mount --make-rshared dir
       mount --make-rslave dir
       mount --make-rprivate dir
       mount --make-runbindable dir
A device can be given by name, say /dev/hda1 or /dev/cdrom,
or by label, using  -L label  or by uuid, using  -U uuid .
Other options: [-nfFrsvw] [-o options] [-p passwdfd].
For many more details, say  man 8 mount .

I got this when i tried to do it anouther way

gnomes@gnomes:~$ sudo mount -o remount,rw '/dev/sdb1 on /media/THIRSTY 2TR'
[sudo] password for gnomes: 
mount: can't find /dev/sdb1 on /media/THIRSTY 2TR in /etc/fstab or /etc/mtab

I tried this today.

gnomes@gnomes:~$ sudo dosfsck -a /dev/THIRSTY 2TR
[sudo] password for gnomes: 
usage: dosfsck [-aAflrtvVwy] [-d path -d ...] [-u path -u ...]
  -a       automatically repair the file system
  -A       toggle Atari file system format
      -d path  drop that file
  -f       salvage unused chains to files
  -l       list path names
  -n       no-op, check non-interactively without changing
  -p       same as -a, for compat with other *fsck
  -r       interactively repair the file system
  -t       test for bad clusters
  -u path  try to undelete that (non-directory) file
  -v       verbose mode
  -V       perform a verification pass
  -w       write changes to disk immediately
  -y       same as -a, for compat with other *fsck

I try using a suffix, with the command i entered but it just pops up this same list again

  • can you post the content of /etc/fstab? – Alexandre Jan 22 '12 at 19:47
  • sorry I misread your question, you are talking about an external HDD. That information is not relevant. – Alexandre Jan 22 '12 at 20:01
  • please open a terminal, type mount and update your question with that output – Alexandre Jan 22 '12 at 20:07
  • The hard disk is not mounted according to 'mount'. – Richard Jan 23 '12 at 1:32
  • 1
    @searchfgold6789 3rd last line >>> /dev/sdb1 on /media/THIRSTY 2TR_ type vfat (rw,nosuid,nodev,uid=1000,gid=1000,shortname=mixed,dmask=0077,utf8=1,showexec,flush,uhelper=udisks) – One Zero Jan 23 '12 at 1:43

I finally solved my problem!!!! I used the disk utility tool in ubuntu 11.10 and tried to check file system. It popped up an error saying that the disk was mounted, cation of loss of data. I then proceeded to cancel and unmount the drive, then scan. After about three min a box appeared that said 240 kb of data was giving an error due to a faulty unmount while writing. I hit ok to delete, now my external is up and running with full read/write capability's!!!


I had a similar problem. Today I tried to copy a directory to my external Seagate FreeAgent 1.5TB external drive (FAT32 lba). Everything on it had suddenly become read only. I could not change permissions to the directories even as sudo. Tried everything I could think of even firing up the much hated Windows Vista partition which has destroyed countless years of DATA on another drive.

I discovered that one tiny sub directory had an error I could not delete it so I rebooted the machine trying backtrack (A Root Only distro) and Xubutu again with no luck. I read about some Windows users having similar issues and fired that up again only to see the dreaded chkdsk screen come up during boot.

Well this time instead of destroying everything on my drive it found and 'fixed' the bad sub directory. It created the stupid and useless "FOUND.001" dir and placed the contents of the bad dir in it, which I promptly deleted using Xubuntu. The drive is now fixed and I hate to admit it but windows chkdsk was what fixed it.

I DON'T RECOMMEND this as the 1st thing one should use for file system problems because in my experience it has always destroyed perfectly good file systems but in this one instance of 30+ years of IT it actually did some good. Try it as a last resort before reformatting and destroying your data anyways.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.