12

I just installed Kubuntu 17.10 (reinstall, from 17.04), keeping my old /home, but formatting/reinstall to /boot and /

When it started up after installing, I noticed the sound icon in tray being the "speaker + red line", indicating no sound. Systray Sound Icon > Dropdown say:

no output or input devices found

muted-icon

In Settings, I can't change anything related to audio since the system claims there's nothing there. Settings > Multimedia > Audio Volume. No ouput/input device found.

settings1 settings2

Strangely enough, Spotify and VLC is making sounds. But not Firefox, not Pillars of Eternity (Steam (Flatpak)). And nothing show up in settings. Those pics were taken while playing music in Spotify.

If I open Volume Control (Menu > Multimedia > PulseAudio Volume Control), I get a box displaying the following message:

Connection to PulseAudio failed. Automatic retry in 5s. In this case this is likely because PULSE_SERVER in the Environment/X11 Root Window Properties or default-server in client.conf is misconfigures. The situation can also arise when PulseAudio crashed and left stale details in the X11 Root Window. If this is the case, then PulseAudio should autospawn again, or if this is not configured you should run start-pulseaudio-x11 manually.

These was no countdown (5s), but the window did blink twice to something to the effect of "trying to connect to PulseAudio". Nothing happend after that.

I tried start-pulseaudio-x11. Output:

Connection failure: Connection refused
pa_context_connect() failed: Connection refused

My sound device is connected via standard Jack (normal speakers). No HDMI or anything. Two monitors connected via DP. Had no problems with it on 17.04.

I tried the following, from an old question: mv ~/.pulse ~/.pulse_backup

Result: mv: cannot stat '/home/USER/.pulse': No such file or directory


TL;DR: Audio doesn't work after installing Kubuntu 17.10 (/home from 17.04). No settings available in audio Settings. Sound from VLC and Spotify, but not Firefox, game/steam. Error message say PulseAudio failed.

9

I had the same problem and seeing the logs in /var/log/syslog I had an error for pulseaudio daemon:

[pulseaudio] module.c: Module "module-switch-on-connect" should be loaded once at most. Refusing to load.

So I opened /etc/pulse/default.pa and edited it using # to disable 3 lines:

#.ifexists module-switch-on-connect.so
#load-module module-switch-on-connect
#.endif

Maybe it'ś not the best solution but it solved my trouble.

  • 2
    Solved it for me, many thanks! This should really not happen after an upgrade... – thw24 Jan 16 '18 at 13:22
  • Solved for me too. Great! – gconcon Apr 9 '18 at 14:51
5

I have solved this by reinstalling pulseaudio.

Pay attention: if you have some custom edits inside /etc/pulse, they get lost if executing rm -rf /etc/pulse as shown below! In my case there are only a hand full of files that have been reinstalled.

Update 2019: take care if package plasma-desktop is uninstalled while removing pulseaudio. Reinstall before booting, otherwise your system may not boot properly.

  • apt-get remove --purge pulseaudio
  • rm -rf /etc/pulse (maybe remove $HOME/.config/pulse also)
  • apt-get install pulseaudio
  • apt-get install plasma-desktop
  • reboot

This also deinstalled some other packages (like oss*) which have not been reinstalled, and in my case, I don't miss them at all. ;)

[EDIT]

If your card is listed by something like sudo aplay -l, but not listed in pavucontrol, your card may be blocked by further processes. Check that sudo fuser -v /dev/snd/* doesn't list any other processes than pulseaudio. In my case when upgrading to kubuntu 19.04 it was blocked by squeezelite process, so I stopped and disabled squeezelite and everything was fine:

$ sudo fuser -v /dev/snd/*
/dev/snd/controlC0: root  872 F..... squeezelite
/dev/snd/pcmC0D0p:  root  872 F....m squeezelite
[... bad ...]
$ sudo systemctl disable squeezelite
$ sudo systemctl stop squeezelite
$ pulseaudio -k
$ sudo fuser -v /dev/snd/*
/dev/snd/controlC0: myUsername 1459 F..... pulseaudio
[... good ...]
$ pavucontrol

... et voila! My soundcard is available inside pavucontrol again.

  • Thanks this method worked for me. It's most accurate, in my opinion. – nullptr Sep 14 at 14:21
3

I had the exact same problem (same symptoms) and ended up wasting hours looking for a solution. I solved the issue by editing default.pa to statically load modules and replaced hw:1,0 with hw:0,0

sudo nano /etc/pulse/default.pa

Content to change:

load-module module-alsa-sink device=hw:0,0  
load-module module-alsa-source device=hw:0,0  
load-module module-null-sink  
load-module module-pipe-sink  

Save and exit, then run:

sudo alsa force-reload  
pulseaudio -k  
start-pulseaudio-x11  

Hopefully you have sound at this point.

  • Thanks for the answer, but I just went ahead and solved it the old fashion way, by reinstalling the OS :) I'll put this answer in my "Tips and Tricks" document, in case I need it again in the future, however! – Edward Alekos Nov 23 '17 at 9:21
  • 1
    had this issue with Thinkpad t470 on Ubuntu 18.04, This fixed it. – Ben DeMott May 8 '18 at 15:37
  • following helped me. sudo alsa force-reload && pulseaudio -k && start-pulseaudio-x11 – Aruna May 14 '18 at 21:48
0

I managed to get the audio again, but the volume controls does not work any more neither the icon in tray appears.

I reinstalled completely the pulseaudio, and in the same way alsa, as in @ChristophS' answer:

  • apt-get remove --purge pulseaudio
  • rm -rf /etc/pulse
  • apt-get install pulseaudio
  • reboot

Also edited the lines as in @Carla sousa's answer:

So I opened /etc/pulse/default.pa and edited it using # to disable 3 lines:

#.ifexists module-switch-on-connect.so
#load-module module-switch-on-connect
#.endif

Then, I went to the system configuration as follows:

Kubuntu main menu System settings

After that, to the Hardware > Multimedia section:

Hardware > Multimedia section in Kubuntu 17.10

And finally, I chose the build in driver:

enter image description here

As i said before, I got the sound again. But I cannot control it. Some idea?

0

I ran into same problem. After installing pavucontrol I restarted my system and now it's detecting my sound card and headphones.

sudo apt-get install pavucontrol

In case pavucontrol giving errors after installation, restart your system and they will gone.

Hope this helps others too.

0

try to find in .config/ if there another folder that config the pulse in my case it was google-chrome-remote-desktop app, that was create another profile with pulse-audio config that prevent the normal profile to load

0

I'm having the same problem in Kubuntu 17.10. I cannot say what the cause was, it happened after I plugged in the HDMI cable or after I paired a bluetooth speaker and changed the output audio stream to it. After some searches I mixed up some solutions. Audio seems to work now but I'm wondering if this is a good or bad solution. What I did was:

  • sudo apt-get remove --purge pulseaudio
  • sudo rm -rf /etc/pulse
  • sudo apt-get install pulseaudio
  • sudo reboot

Audio was up but there was no way to control it. Icon in the system tray disappeard. So I did:

  • sudo apt-get install plasma-pa
  • sudo reboot

At the reboot the icon was in the system tray but audio was mute and not working, exactly like here. So I removed plasma-pa and installed kmix. Doing this, audio is working now.

  • sudo apt-get remove plasma-pa
  • sudo apt-get install kmix

Is this a good solution? What's the problem with plasma-pa?

Thanks, Luca

  • 2
    if your intention is to ask a question, you should ask a question instead of posting an answer. We delete posts in the answer section that are actually questions, but here I am not sure whether you are partly proposing a solution, or just asking a question of your own. – Zanna May 4 '18 at 8:40
0

@peterling 's answer worked for me it is the last one on this page: askubuntu.com/questions/70560/why-am-i-getting-this-connection-to-pulseaudio-failed-error

He said I had to enter this in the terminal:

sudo pulseaudio -k
pulseaudio --start

this is what it looked like on the terminal:

lubuntu@lubuntu:~$ sudo pulseaudio -k
E: [pulseaudio] core-util.c: Home directory not accessible: Permission denied
E: [pulseaudio] main.c: Failed to kill daemon: No such file or directory
lubuntu@lubuntu:~$ pulseaudio --start
N: [pulseaudio] main.c: User-configured server at {2d68ac8ceac9497599efde6fcfca4f8c}unix:/run/user/999/pulse/native, which appears to be local. Probing deeper

After this I ran pulseaudio volume control From using the normal shortcut by clicking on it in lUbuntu 16.10 You're using a much newer version of KUbuntu but I think this might work for you because we have this in common: "

I tried start-pulseaudio-x11. Output:

Connection failure: Connection refused
pa_context_connect() failed: Connection refused

"

0

Don't have enough rep to comment, but I tried the 3rd solution above by ChristophS. While this looks like a good solution, on Kubuntu 18.10 using purge uninstalled my plasma-desktop and kubuntu-desktop. I had a bunch of unnecessary packages listed from a wine uninstall, I plan to reinstall. Needless to say caused quite the confusion, especially paired with the permission changes which ended up being the cause, which I thought messed with the desktop.

Lesson being: be careful what you purge! I think there should be a comment on the above solution to warn about the current inclusion of desktop with purge pulseaudio.

apt -s remove --purge pulseaudio
Purg kubuntu-desktop [1.379]
Purg plasma-pa [4:5.13.5-0ubuntu2]
Purg plasma-desktop [4:5.13.5-1ubuntu4]
Purg libcanberra-pulse [0.30-6ubuntu1]
Purg pavucontrol-qt [0.4.0-1]
Purg pulseaudio-module-bluetooth [1:12.2-0ubuntu4]
Purg pulseaudio [1:12.2-0ubuntu4]

If hack from the above link works, might be the permissions: HOME=/tmp/$USER pulseaudio --start

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.