0

I've got the problem that 2 USB devices that I'd like to connect to my laptop with Ubuntu 17.10 won't mount any more.

The devices are an iPhone 4s with iOS 9.3.5, and a Kobo tablet with Android 4.2.2 (not PTP nor MTP, both worked earlier). My GoPro for example, still mounts automatically after plugging in.

The story is, I updated from Ubuntu 16.04 to 17.10 and connected my iPhone to transfer some pictures, that's all I usually did. It still did work, but it didn't show all the pictures any more (this turned out to be an iPhone setting). But before I realised that, I started messing around with the libimobiledevice-department (so to say). Ended up deleting it, to attempt to reinstall, but automatically got a lot more deleted and couldn't get in the Ubuntu desktop environment anymore. Ended up reinstalling ubuntu-desktop , all sorted, but now after a few days trying and Google-ing I can't get my iPhone working with Ubuntu anymore.

I didn't test the Kobo tablet after upgrading to Ubuntu 17.10, but it's too much of a coincidence to me that it also doesn't work anymore.

Both devices do show up correct when I do lsusb. Laptop is an Acer Aspire V3-571.

I'm guessing that with the removal from libimobiledevice accidentally more has been removed than I reinstalled later.. what could that be?

  • Please see this referring to an Android device. It may / may not help. askubuntu.com/questions/975089/… – Piloti Nov 14 '17 at 7:37
  • A little bit, with jmtpfs I can mount the Kobo manually, but nothing shows up in Nautilus automatically. When this worked, I figured that I can mount my iPhone manually with ifuse, but only manually. Both devices showed up in Nautilus automatically before, like all other usb devices (GoPro, USB Sticks) still do, but just not these two. – Alwin Nov 15 '17 at 5:32

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.