2

With a fresh copy of 17.10 ubuntu installed. I have found a repeatable error which I believe is messing up my wine installation permanently. After the error I simply format the system and retry another time. The error message is encountered when installing winehq. Both stable and staging versions run into the exact same problem.

I cannot find an answer on the internet. Please help if you can.

Selecting previously unselected package libtxc-dxtn-s2tc:i386.
Preparing to unpack .../150-libtxc-dxtn-s2tc_1.0+git20151227-2_i386.deb ...
Unpacking libtxc-dxtn-s2tc:i386 (1.0+git20151227-2) ...
Errors were encountered while processing:
 /tmp/apt-dpkg-install-mh7wRK/137-libsane1_1.0.27-1~experimental2ubuntu1_i386.deb
E: Sub-process /usr/bin/dpkg returned an error code (1)
1
  • Could you please add a little more detail? What exactly did you do, what did you want to expect to happen and what happened instead? Did you encounter any warning or error messages? Please reproduce them in their entirety in your question. You can select, copy and paste terminal content and most dialogue messages in Ubuntu. Please edit your post to add information instead of posting a comment. (see How do I ask a good question?) Dec 14 '17 at 17:31
4

I met the same problem and solve it. This is caused by a bug in sane-backends.

First, remove Wine, then execute:

sudo apt-get -o Dpkg::Options::="--force-overwrite" install libsane1:i386

and then install Wine again.

3

Try :

sudo apt-add-repository --remove ppa:ubuntu-wine/ppa
sudo apt purge winehq-stable wine-mono wine-gecko winetricks 

Basically ppa remove and purge your current wine installation using above commands, then :

sudo rm -rf /var/lib/apt/lists/*
sudo apt clean
sudo apt autoremove
sudo apt update

Now to install winehq-stable

sudo dpkg --add-architecture i386 
wget -nc https://dl.winehq.org/wine-builds/Release.key
sudo apt-key add Release.key
sudo apt-add-repository https://dl.winehq.org/wine-builds/ubuntu/
sudo apt-get update
sudo apt-get install --install-recommends winehq-stable
sudo dpkg --configure -a

Above is the the current installation procedure as the launchpad Wine ppa is DEPRECATED, see link : https://launchpad.net/~ubuntu-wine/+archive/ubuntu/ppa for details.

EDIT : If you are still facing a problem with libsane package, report a bug to https://launchpad.net/ubuntu/+source/sane-backends there is a chance that this bug may have been already reported and fixed.

5
  • I have tried those exact steps to install wine on a fresh Ubuntu... several times. I always get the error message I posted.
    – Daniel
    Nov 14 '17 at 4:43
  • 1
    @Daniel try : " sudo apt-get install wine-staging winehq-staging winetricks " If that fails try " sudo apt-get install --install-recommends winehq-devel "
    – himanshuxd
    Nov 14 '17 at 20:02
  • @Daniel Also read my answer for edit at end.
    – himanshuxd
    Nov 14 '17 at 20:22
  • 1
    himanshuxd, Had a similar issue while installing winehq-staging. My system automatically reported it as a bug (bugs.launchpad.net/ubuntu/+source/sane-backends/+bug/1795330). Your solution worked great. No errors reported. Thank you.
    – hienz1
    Oct 1 '18 at 9:31
  • @hienz1 glad I could be of help.
    – himanshuxd
    Oct 2 '18 at 14:24
-2

in synaptic search for "libsane" and install all the extras, devs etc. worked for me on ubuntu studio 17.10

1
  • 2
    I don't think that's going to solve package dependency issues with packages stemming from some PPA. Dec 14 '17 at 17:32

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.