0

I wanted to install Linux on the second hard drive. On SSD I have already installed Windows 10. Here's what I did:

So, /dev/sda is a HDD where I want to install Ubuntu, and /dev/sdb is a SSD.

I have created an EFI partition (dev/sda1), then root and /home on HDD (/dev/sda), changed device for boot loader installation on (/dev/sda1 - EFI part). Then I installed Ubuntu with no problem. But after all, even with changing the boot priority, only Windows 10 boots. There is no grub menu.

I also tried to install both Windows 10 and Linux on the SSD - the same situation.

Any suggestions/advice?

EDIT:

I also tried installing Linux on the same drive as Win. I have chosen the first option when installing, splitted the drive automatically. Still only Win boots...

EDIT2:

Fed up with everything I have put my SSD drive out of laptop. I wanted to avoid that but it was easy.

So, I have tried installation again. I used Rufus to make bootable usb (with EFI partition scheme only). In BIOS boot option was set to UEFI. But after reinstallation and rebooting I got "No bootable devices" message. So I changed boot mode to legacy mode... and Linux booted.
I suppose something went wrong when I was installing Windows (I had problems with MBR and GPT partitioning). My drives (both SSD and HDD) have been converted to GPT with Windows already installed. So maybe here is the problem?

  • Are you sure that ubuntu installed in EFI mode? Grub-efi doesn't ask where to install, because there is only one place for it (the EFI partition). – ravery Nov 12 '17 at 20:24
  • Yes I am sure. I made bootable usb with option "efi only". But I have forgotten, the Windows' efi partition is on ssd. – moorzyn Nov 12 '17 at 22:07
  • What brand/model system? Some have unique requirements/settings. Are both drives gpt? May be best to see details, you can run from your Ubuntu live installer or any working install, use ppa version not older Boot-Repair ISO: Post the link to the Create BootInfo summary report. Is part of Boot-Repair: help.ubuntu.com/community/Boot-Info and: sourceforge.net/p/boot-repair/home/Home – oldfred Nov 14 '17 at 23:23
0

Is the BIOS set to boot from the correct hard drive?

/dev/sda - Linux

/dev/sdb - Windows

What HDD did you install grub to? Try switching your default boot HDD to the other hard drive. Please make sure you have selected the correct option...

  • Boot priority is set correctly. HDD does not appear in boot menu (only Windows Boot Manager which is on SSD and Bootable USB). – moorzyn Nov 12 '17 at 22:08
  • @moorzyn -- sounds like you didn't use The flagged EFI Partition on the first drive. – ravery Nov 13 '17 at 1:07
  • I checked it with GParted, it has boot flag and I am sure I have chosen this partition when installing. – moorzyn Nov 13 '17 at 21:16

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.