2

I recently upgraded to Ubuntu 17.10. As my laptop is rather on the weak side (performance wise), I grew quite uncomfortable with the new desktop as everything seemed to take longer, the laptop being slower overall.

So, I installed LXDE, lubuntu-session packages, etc., to make a transition to the more lightweight LX desktop environment. I am super happy about it, as the system now feels super fast and responsive.

One issue remains: If my session gets locked (by timeout, laptop lid close, or manual lock) I end up with a black and empty screen. Not even a mouse pointer, not responding to any clicks or simple key presses. The only remedy I found was killing/rebooting the entire machine. After some playing around, I found that Ctrl+Alt+F1 takes me back to the login screen.

I tried to google for this problem, but didn't find any help: Several similar problems were discussed, like having no login screen right after boot (which is not my problem), of another solution talking about "Light Locker Settings" and turning off/on some stuff - but I don't seem to have this menu...

I do not really understand what's going on, and why I seem to end up at the wrong Ctrl-Alt-F* interface.

For me it's only a thing of minor to medium importance, as I found a way to work around it. But, of course, I would be glad if someone could point me to a clean solution.

(A solution is great, but if you could elaborate your answer a bit, I would be very grateful, as I'd really like to learn more about the inner workings of my system.)

  • 1
    I am having the same issue on Ubuntu 18.10 – maharvey67 Oct 19 '18 at 18:33
-1

Press Ctrl-Alt-F1 to go to a virtual terminal, and log in. Issue this command:

ps ax | grep lock

If you see light-locker running, kill it

killall light-locker

Return to your gui by pressing Ctrl-Alt-F7. Hopefully it is unlocked now.

  • This doesn't really solve the issue, it's only a workaround. (And one might as well just go to a console (Altc-Ctrl-F1), then go back to light-locker (Ctrl-Alt-F8) and just enter the password. – zrajm Apr 9 at 2:44
  • True, I never found a solution. I finally "fixed" it by disabling light-locker and installing xscreensaver. – maharvey67 Apr 9 at 20:18

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.