2

I use KolabNow for my email needs rather than other services like Gmail or Outlook. I spend a lot of my time in the terminal and I am hoping to setup a way to read and send emails without leaving the terminal.

So far I have read a tutorial made for Gmail but I have entered the details provided here by KolabNow instead.

Here's my muttrc file:

set ssl_starttls=yes
set ssl_force_tls=yes
set imap_user = 'jacksewell@kolabnow.ch'
set imap_pass = ''
set from='jacksewell@kolabnow.ch'
set realname='Jack Sewell'
set folder = imap://imap.kolabnow.com/
set spoolfile = imap://imap.kolabnow.com/INBOX

set header_cache = "~/.mutt/cache/headers"
set message_cachedir = "~/.mutt/cache/bodies"
set certificate_file = "~/.mutt/certificates"
set smtp_url = 'smtp://smtp.kolabnow.com/'
set move = no
set imap_keepalive = 900

Here's the output when I try to send mail:

This certificate belongs to:
*.kolabnow.com

Domain Control Validated


This certificate was issued by:
 COMODO RSA Domain Validation Secure Server CA
 COMODO CA Limited

 Salford  Greater Manchester  GB

This certificate is valid
from Wed, 28 Dec 2016 00:00:00 UTC
to Fri, 26 Jan 2018 23:59:59 UTC
SHA1 Fingerprint: AD00 8907 9BFB 568E 4C40 C99C 190E 01C0 6438 0018
MD5 Fingerprint: 7E2B 4E72 4A08 59DC 5803 D4CE 7326 7333

WARNING: Server hostname does not match certificate

Do I need additional software installed/configured?

5
  • @dessert, yes I am asking how you would setup an email client. I'm wanting to have it so I can check and send emails (not just the single email) from my terminal. – user758870 Nov 11 '17 at 21:03
  • @dessert, I have edited the OP. – user758870 Nov 11 '17 at 21:17
  • What happens when you try to send yourself a message? The only way to really know is to Test!. – waltinator Nov 11 '17 at 21:35
  • That's too hard to read. Please Edit askubuntu.com/posts/975544/edit your post, paste the text in, select the text and click on {}. – waltinator Nov 11 '17 at 21:54
  • @waltinator I have edited the OP. I'll do that from now on. – user758870 Nov 11 '17 at 21:58
1

Disclaimer: Neither did I know mutt before doing the research for this nor did I test this configuration, I just combined information from the cited sources here. There is a chance this is folderol.

I'd just take a minimal configuration and change only the crucial settings first. With the information from kolabnow.ch let's use the one on dev.mutt.org and adapth it with the help of the extensive manual to build a simplistic ~/.muttrc:

# IMAP settings, automatically log in to this mailbox at startup
set spoolfile = "imaps://jacksewell@kolabnow.ch:PASSWORD@imap.kolabnow.com:143/INBOX"

# SMTP settings
set smtp_url  = "smtps://jacksewell@kolabnow.ch:PASSWORD@smtp.kolabnow.com:587"

# Define the “=” shortcut and the entry point for the folder browser (c?)
set folder    = "imaps://imap.kolabnow.com/INBOX"
set record    = "=Sent"
set postponed = "=Drafts"

This uses the neat URL syntax where we can cram the whole information needed to communicate with the server in one single command, I did that leaving just PASSWORD for you to replace. If you want mutt to ask for your password, remove :PASSWORD from both lines. If you decide to store your password in ~/.muttrc don't forget to adjust the file permissions with chmod 600 ~/.muttrc, this prevents others from reading it. Depending on where your mail is stored on the server you might have to adapt the /INBOX path:

If your folders are addressed as sub-folders of your INBOX folder, INBOX should be given as the mailbox component, otherwise leave it empty.

Once you got the correct connection settings you're free to configure mutt's behaviour to your needs, the manual I linked above seems like a good place to start. Additionally, there's the MuttrcBuilder and the config tricks.

4
  • Now I feel like using mutt myself. :( – dessert Nov 12 '17 at 10:11
  • Thank you @dessert. This seems to work but when I send an email and fill in my details mutt displays "Logging in... then does nothing. – user758870 Nov 12 '17 at 21:40
  • Also, when launching mutt it displays: gnutls_handshake: An unexpected TLS packet was received. – user758870 Nov 12 '17 at 21:45
  • 1
    I have opened a new questions for the new issues I've ran into: askubuntu.com/questions/975831/… – user758870 Nov 12 '17 at 22:39
1

This .muttrc works for me with kolabnow.com. You would have to change your server to kolabnow.ch

set my_server       =   imap.kolabnow.com
set my_smtp_server  =   smtp.kolabnow.com
set my_user         =   USERNAME@kolabnow.com
set my_pass         =   PASSWORD

set record          =   "imaps://$my_server/INBOX.Sent Items"
set postponed       =   "imaps://$my_server/INBOX.Drafts"

set from            =   "USERNAME@kolabnow.com"

# Account - SMTP

set smtp_url        = "smtp://$my_user:$my_pass@$my_smtp_server:587"
set smtp_pass       = $my_pass
set imap_user       = $my_user
set imap_pass       = $my_pass
set ssl_force_tls   = yes
set ssl_starttls    = no

#
# Default inbox
#
set spoolfile=imaps://$my_server/INBOX

#
# Default location of mailboxes
#
set folder=imaps://$my_server/INBOX

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy