0

I have problem trying to install an Epson L4150 printer. I found 3 files through http://download.ebz.epson.net/dsc/search/01/search/searchModule :

  L4150 Series Printer Driver Linux 1.0.9 ESC/P-R Driver 2 (generic driver) 10-23-2017
  L4150 Series Printer Driver Linux 1.0.2 Epson Printer Utility 10-23-2017
  L4150 Series Scanner Driver Linux 1.3.22 All-in-one package 10-05-2017

I downloaded first a file called epson-inkjet-printer-escpr2_1.0.9-1lsb3.2_i386.deb, and extracted it. Then I went to Settings -> Printers -> Add one. I managed the installation of the printer driver. After that I tried several times to print a page from Writer, but it failed (The Document Print Status says the status is "stopped", I tried reprint, but no luck).

The second file I downloaded is epson-printer-utility_1.0.2-1lsb3.2_i386.deb, but unfortunately, because I am new to Linux I don't know how to install this printer utility.

The third file I downloaded is iscan-bundle-1.0.0.x86.deb.tar.gz. After extracting it, I found there an install.sh file. I managed to run sudo .../install.sh, but after installation, I didn't find any scanner inside the Settings -> Hardware area. I don't know if the scanner installation is OK or not.

  • If you can't solve your problem, you can use Gutenprint to help you resolve it – Doudou Nov 11 '17 at 18:41
  • Thanks for good suggestion. I found Gutenprint and will give it a try. – Neverhurry Nov 11 '17 at 18:48
  • I went to Ubuntu Software Center and found Printer driver for Epson Inkjet that use ESC/P-R, installed this driver, but had to manually add through Setting - Hardware - Printer - Add one... Took about 1 hour and finally the printer starts to work. :D Not found any Utility program yet. Still don't know how to install the scanner driver so that I can use the scanner. Hope somebody can help! – Neverhurry Nov 11 '17 at 19:35
  • You should not extract .deb packages. To install, for example, epson-inkjet-printer-escpr2_1.0.9-1lsb3.2_i386.deb, open a terminal window and type: sudo dpkg -i epson-inkjet-printer-escpr2_1.0.9-1lsb3.2_i386.deb. – mikewhatever Nov 11 '17 at 19:49
  • Thanks. @mikewhatever, I follow your method and get this: paul@paul-G31T-M2:~$ sudo dpkg -i imagescan-bundle-ubuntu-16.04-1.3.22.x86.deb [sudo] password for paul: dpkg: error processing archive imagescan-bundle-ubuntu-16.04-1.3.22.x86.deb (--install): cannot access archive: No such file or directory Errors were encountered while processing: imagescan-bundle-ubuntu-16.04-1.3.22.x86.deb what did I do wrong? – Neverhurry Nov 11 '17 at 20:50
1

By using the network plug-in, you can connect to a scanner that is directly attached to the network. Please note that scanning over the network is only supported in a client/ server setup. Scanners directly attached to the network are not supported.

Connect the scanner to the network and set the IP address. For information on how to set the IP address, refer to the user manual shipped with your scanner.

Please edit /etc/imagescan/imagescan.conf file by using root privileges as below.

Example:

[device]
net.udi = networkscan:esci://[IP address]:[Port number]
net.vendor  = Epson
net.model   = DS-XX00
net.name    = My Network Scanner
vendor : Vendor name on Main Window.
model : Model name on Main Window.
name : If you want to change the display name, specify this item.
If this item is not specified, vendor+model is displayed.

*[Port number] must be set to 1865
*vendor / model / name = optional items

exp) When the IP address is xxx.yyy.zzz.www, specify as follows.
net.udi = networkscan:esci://xxx.yyy.zzz.www:1865

Launch Image Scan v3. If it identifies the scanner on the network properly, it will work without any problems. At this time, if multiple scanners are connected, select the appropriate scanner as well as local connection. See “6.4.3. Select scanner”

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.