5

I have a UE Boom 2 Speaker. With Ubuntu 16.04 I was never really able to connect to it via Bluetooth (sound was awful), but when I fresh installed Ubuntu 17.10 beta (one month before release), I was able to connect easily with good sound quality.

But a few days after the official release of Ubuntu 17.10, the Bluetooth connection crashed, and I was not able to connect again, unless I reset the speaker and rebooted my computer. Then I would be able to connect again, but after a few minutes, it would break again.

The default Bluetooth settings window freezes when I am trying to reconnect.

What could be the cause? Unfortunately, I don't know which logs I check to diagnose the problem - please comment if you can advise and I will add any necessary information.

I have tried with another Bluetooth device (from another brand: D-LINK), and I have the same problem.

I am using a ThinkPad T460s (which comes with Bluetooth 4.1).

12
  • A couple of questions for you : [A] Do you have any other BT devices to be able to test ? [B] If yes [or you can borrow one] is the [poor] quality same on both devices or is it different [C] How far away is the speaker? [D]If the speaker is next to your computer what is the quality like [E] Which BT Chip do you have?
    – Piloti
    Nov 11, 2017 at 15:34
  • With 17.10, the sound has never been awful. [A] I don't have other BT audio devices, I could try next week. [B] The sound is absolutely perfect, when connected however. [C] Next to my computer, a few centimetres away. [D] see point B. [E] I absolutely don't know how to determine that and googling doesn't help... Nov 11, 2017 at 15:45
  • Hi @JohannesLemonde : when the speaker is a few centimetres from the computer does it still drop or is it stable ? For the chip, which PC are you using? Finally, if you /could/ borrow another BT Speaker / headset and duplicate, that would be excellent. It will help isolate the issue. Also, does the UE Boom stay stable with anything else ?
    – Piloti
    Nov 11, 2017 at 16:34
  • I've just borrowed a bluetooth to jack adapter and am listening music through it. As of now, it works, but the bug may still come (Usually it happens half an hour after I began the connection). I forgot to mention : I suspect the bug to happen when I open or close specific programs or windows from my computer. But I have no proof of that... For the computer I have, it is the ThinkPad T460s. I couldn't find the bluetooth chip's name, but the spec says it has Bluetooth 4.1 www3.lenovo.com/us/en/laptops/thinkpad/thinkpad-t-series/… Nov 11, 2017 at 17:29
  • Confirmed : The same bug happens with other bluetooth devices too. Nov 11, 2017 at 17:30

1 Answer 1

1

maybe it will help you - it helped me:

sudo alsa force-reload

and then:

sudo reboot
2
  • Thanks to you, I tried again to connect to my Bluetooth device, and it worked - for now !! But actually I absolutely don't know if the connection will perdure, and neither if alsa was the cause : since november there have been plenty of updates anyway !! But for now it works !! thank you very much. Mar 3, 2018 at 16:56
  • Johannes, did this solution fix your problem? I'm experiencing the same thing with my bose bluetooth headphones. Everything is working great for a few minutes and then the connection is lost..
    – Edvin
    Apr 11, 2018 at 8:08

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .