0

This question already has an answer here:

After a Windows 10 update, I'm experiencing a problem with GRUB: the system boots directly into Windows and i don't have the chance to select Ubuntu. I tried to use a live USB of Boot-Repair (first the recommended option and then with the "purge the grub" option flagged). I also tried to use these commands in an administrator command prompt (Windows):

bcdedit /set {bootmgr} path \efi\ubuntu\shimx64.efi
bcdedit /set {bootmgr} path efi\ubuntu\grubx64.efi

Here is the Boot-info summary

Any tips?

marked as duplicate by Eric Carvalho, Thomas, Zanna, Kulfy, WinEunuuchs2Unix Dec 30 '18 at 13:42

This question has been asked before and already has an answer. If those answers do not fully address your question, please ask a new question.

-1

If your firmware supports Boot file selection then go as per stated by #ravery's answer. Open boot settings of your computer then start seeking if there is an option provided somewhere to select boot file. If not then you have two options as per my knowledge. Either search for commands from google that will change your OS Boot file-if you not wish to loose your data in /root partition and if you can afford the overhead of reinstalling /root and updating your system again then go through the method described by me below. If you have not installed any specific software and if you could afford installing /root partition again then do it best way. It will simply install grub again. None of the the other partition will be affected and none of the data other than /root will be affected.Boot through live medium & Open G-parted. Choose /root partition then select (-) from the bottom. Select un-allocated space & press (+). Then again make /root partition . Look for column named FORMAT in the top if it is not checked in front of /root, then make it checked otherwise it's OK. DEVICE FOR Boot loader installation select whole disk /dva/sda it will automatically overwrite the Windows boot file. Only those partition that are checked in the format partition are going to be formatted. Feel free to select INSTALL NOW option. None of the data other than the /root partition will be lost.

Then select done.

  • EFI does not use the MBR. installing to /dev/sda is for Legacy boot only – ravery Nov 12 '17 at 12:26
-1

I see that /efi/boot/bootx64.efi is present. Some EFI systems will ignore OS boot options if the device boot path is present.

If the systems firmware allows OS boot selection, rename /efi/boot to test booting via OS.

If the firmware only allows Device boot selection, then /efi/boot/bootx64.efi needs to be replaced with /efi/ubuntu/shimx64.efi. Relocate the original file in case you want to restore it later. Then copy shimx64.efi to the /efi/boot/ directory and rename it bootx64.efi.

  • how would you rename or copy those files? – nmz787 Jan 19 at 3:30

Not the answer you're looking for? Browse other questions tagged or ask your own question.