18

What's going on here? I've installed the Dash to Dock extension on Ubuntu 17.10. Everything was cool, and as I was trying to hone and tweak the look of my desktop, at some point the shortcuts bar (dock?) on the left is duplicated.

IMG:
(Click image to enlarge)

The default, which normally disappears with Dash to Dock, is there underneath the one that usually shows up when I install Dash to Dock. Why?

I've tried to go through the options for Dash to Dock, the GNOME Tweak Tool, and the regular Ubuntu settings, but I can't figure it out.

  • 1
    Once you have Dash to Dock installed, you can just sudo apt remove gnome-shell-extension-ubuntu-dock. That's what I ended up doing to resolve issues like this. Bye bye! – Shibumi Dec 13 '17 at 15:42
  • @Shibumi It would certainly get rid of the Ubuntu dock, but it will also remove the ubuntu-desktop meta-package which may break stuffs later. – pomsky Jul 28 at 0:05
16

Running Dash to Dock along with the default Ubuntu Dock is not a good idea. As Ubuntu Dock is a fork of Dash to Dock (and hence they share many same schemas), issue like this is not really surprising.

Disable one of the two extensions (Ubuntu Dock and Dash to Dock) using Tweaks or in some way (refer to this if you want to disable Ubuntu Dock).

| improve this answer | |
  • 1
    Pomsky is right, I had the same issue with 17.10, for me Dash to Dock was causing the problem – Doudou Nov 11 '17 at 12:53
  • 1
    I have the same problem and DID disable the ubuntu dock before installing dock to dash. So I don't know about others, but this is not working for me. – verpfeilt Nov 19 '17 at 17:48
  • @verpfeilt It's not easy to disable Ubuntu Dock in the default Ubuntu session. The safest option is to install vanilla GNOME, Ubuntu Dock is disabled by default there. You may also consider leoperbo's answer to this question. A potentially unsafe option is to remove the folder for the dock from /usr/share/gnome-shell/extensions. – pomsky Nov 19 '17 at 18:29
  • 1
    Okay, I assumed with "Tweaks" you meant gnome-tweak-tool. This is what did not work for me. – verpfeilt Nov 19 '17 at 18:47
  • 2
    To remove it I've done sudo apt remove gnome-shell-extension-ubuntu-dock. Then log out / log in and Dash to Dock was working properly :) – Jérémy Pouyet Oct 18 '18 at 7:48
7

I did the following steps:

  • Open Dash to Dock settings
  • Got to the 'Poistion and size' tab
  • Check the option 'Show on all monitors'

This fixed the problem for me. Hopefully it works for you too. Also make sure Ubuntu dock is disabled.

| improve this answer | |
  • This worked for me! Any idea how this setting influences dock behavior on activities screen? – everton Jul 30 '18 at 18:49
  • I can only make educated guesses as to why it worked. Unfortunately i cant provide you with anything concrete. – chai_and_kaapi Oct 11 '18 at 7:31
  • Worked for me on Ubuntu 18.10, although it does not make sense. – andreas Feb 2 '19 at 0:59
  • This worked for me. Maybe there is something to do with installing ubuntu with a existing home partition? – Stargazer Jul 18 '19 at 14:40
5

I have been playing with similar issues: Gnome favorites bar was showing in activities view and dock was showing on lockscreen; as pomsky says, all of this issues are associated with the combination of Ubuntu Dock and Dash to Dock.

I found this workaround for customize the dock with almost all the options that Dash to Dock offers:

  1. Install Dash to Dock.
  2. Make all your customization.
  3. Remove Dash to Dock (from https://extensions.gnome.org/local/).
  4. Logout and login.

Although Dash to Dock was removed, the customization (position, size, behavior, appearance) persist on Ubuntu Dock and the issues (docks overlapped, dock shows on lockscreen and favorites shows on activities view) are not present any more.

Notes: with this method, the only thing that you lost from Dash to Dock is the "Dash to Dock settings" menu from the applications icon, and of course, the Dash to Dock settings entry in Gnome Tweak Tool. I haven't tried yet, but I think that if you make a change from Dock entry in Ubuntu settings, may be some customization realized with Dash to Dock settings will be lost.

| improve this answer | |
  • This did not work for me, unfortunately. The Ubuntu Dock is now just like before. I read that canonical promised that people would be able to use the normal Dash to Dock extension if they want, so I really wonder why this problem exists. – verpfeilt Nov 19 '17 at 18:45
4

The following is working for me:

  1. Install and configure the "dash to dock" extension
  2. Edit the following file:

    sudo vi /usr/share/gnome-shell/extensions/ubuntu-dock@ubuntu.com/extension.js
    
  3. In the following code block, change the let to_enable = true; to let to_enable = false:

    function conditionallyenabledock() {
        let to_enable = false;
        runningExtensions = ExtensionSystem.extensionOrder;
        for (let i = 0; i < runningExtensions.length; i++) {
            if (runningExtensions[i] === "dash-to-dock@micxgx.gmail.com") {
                to_enable = false;
            }
        }
    
        // enable or disable dock depending on dock status and to_enable state
        if (to_enable && !dockManager) {
            dockManager = new Docking.DockManager();
        } else if (!to_enable && dockManager) {
            dockManager.destroy();
            dockManager = null;
        }
    }
    
  4. Restart your session or do Alt + F2 and type restart

That's it.

| improve this answer | |
0

I was facing the same problem, then I found this nxadm cluadio. It really did the trick.

  1. Remove Dash to Dock extension in case that you have installed.
  2. Use dconf as explained in the link. The text in this step was copied from the same link.

    To prevent Ubuntu Dock to take all the vertical space (i.e. most of it is just an empty bar):

    dconf write /org/gnome/shell/extensions/dash-to-dock/extend-height false
    

    A neat Dock trick: when hovering over a icon on the dock, cycle through windows of the application while scrolling (or using two fingers). Way faster than click + select:

    dconf write /org/gnome/shell/extensions/dash-to-dock/scroll-action "'cycle-windows'"
    

    I set the dock to autohide in the regular “Settings” application. An extension is needed to do the same for the Top Bar (you need to log out, and the enable it through the “Tweaks” application):

    sudo apt install gnome-shell-extension-autohidetopbar
    

    Just to be safe (e.g. in case you broke something), you can reset all the GNOME settings with:

    dconf reset -f /
    

Optional: You can install dconf-editor and explore other settings.

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.