0

I recently replaced Mint with Ubuntu 17.10 on my MacBook (2008) and have noticed that some symbol keys are not properly assigned (namely those between shift and Enter and the letter keys).

Can you help me?

Much appreciated

1

You could switch to ISO layout instead of default by entering following in a terminal:

echo 0 | sudo tee /sys/module/hid_apple/parameters/iso_layout

Note: rebooting will reset this to default.

If everything works like you expect after this command, you can set it permanently using

echo options hid_apple iso_layout=0 | sudo tee -a /etc/modprobe.d/hid_apple.conf 

followed by

sudo update-initramfs -u -k all

and eventually reboot your Mac.

  • So I simply paste that in the Terminal? – Fanboy_killer Nov 11 '17 at 11:14
  • Yes, but rebooting will reset this to default. If everything works like you expect after this command, you can set it permanently using echo options hid_apple iso_layout=0 | sudo tee -a /etc/modprobe.d/hid_apple.conf followed by sudo update-initramfs -u -k all and eventually reboot your Mac. – Doudou Nov 11 '17 at 11:34

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.