After updating from Ubuntu 17.04 to 17.10 hibernate after suspend (hybrid suspend) stopped working. Since switching to systemd I used this solution https://wiki.debian.org/SystemdSuspendSedation (after the solution with a script in /etc/pm/sleep.d also stopped working) but now my computer only enters suspend mode and stays there forever.

systemctl hibernate is working and I don't have a clue why it's not working any more.

How do I make hibernate after suspend working again?

Additional information: I'm using the tuxonice kernel.

edit: What I recently found out is that systemctl suspend and sudo pm-suspend seem to do different things in Ubuntu 17.10, as when I use sudo pm-suspend the old script in /etc/pm/sleep.d works as intended but the systemd style script still does nothing.

  • Do you have a swap file or swap partition? – NerdOfLinux Nov 14 '17 at 21:58
  • 1
    How much RAM do you have, and how big is your swap partition? – NerdOfLinux Nov 14 '17 at 22:14
  • I always was using a swap partition that always worked fine. RAM is 16GB, swap roughly 17GB. But the thing is: it worked before. – joschi Nov 14 '17 at 22:19
  • 1
    But we don't know the conditions under which it worked. After a fresh reboot, hibernate would work because there is enough swap space to store the RAM. After the system is in use, there may not be enough swap to store both the RAM and existing SWAP in the partition. – NerdOfLinux Nov 14 '17 at 22:20
  • As swap is only used if the RAM is full and I barely use half of it there can't be a problem of the swap partition being to small. – joschi Nov 14 '17 at 22:36

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.