0

I have a problem since the last time I did sudo apt dist-upgrade in my ubuntu machone as the one described here. However, none of their solutions worked, starting by the fact that I am not using the low latency kernel.

I follow all the steps that seem to work:

  1. Blacklisting the noveau driver.
  2. Setting nomodeset in /etc/default/grub.
  3. Setting GRUB_CMDLINE_LINUX_DEFAULT="quiet splash nvidia-drm.modeset=1" also in /etc/default/grub (2 and 3 were not set simultaneously).
  4. Installing lightdm.
  5. Reinstalling the nvidia drivers with apt purge ^nvidia and apt install --reinstall nvidia-384.

While (4) finally gave me a login screen, longing in in gnome didn't work.

sudo journalctl -ocat yields:

(II) "glx" will be loaded by default.
(II) LoadModule: "glx"
(II) Loading /usr/lib/x86_64-linux-gnu/xorg/extra-modules/libglx.so
(II) Module glx: vendor="NVIDIA Corporation"
        compiled for 4.0.2, module version = 1.0.0
        Module class: X.Org Server Extension
(II) NVIDIA GLX Module  384.90  Tue Sep 19 17:00:25 PDT 2017
(==) Matched nvidia as autoconfigured driver 0
(==) Matched nouveau as autoconfigured driver 1
(==) Matched modesetting as autoconfigured driver 2
(==) Matched fbdev as autoconfigured driver 3
(==) Matched vesa as autoconfigured driver 4
(==) Assigned the driver to the xf86ConfigLayout
(II) LoadModule: "nvidia"
(II) Loading /usr/lib/x86_64-linux-gnu/xorg/extra-modules/nvidia_drv.so
(II) Module nvidia: vendor="NVIDIA Corporation"
        compiled for 4.0.2, module version = 1.0.0
        Module class: X.Org Video Driver
(II) LoadModule: "nouveau"
(II) Loading /usr/lib/xorg/modules/drivers/nouveau_drv.so
(II) Module nouveau: vendor="X.Org Foundation"
        compiled for 1.19.3, module version = 1.0.15
        Module class: X.Org Video Driver
        ABI class: X.Org Video Driver, version 23.0
(II) LoadModule: "modesetting"
(II) Loading /usr/lib/xorg/modules/drivers/modesetting_drv.so
(II) Module modesetting: vendor="X.Org Foundation"
        compiled for 1.19.5, module version = 1.19.5
        Module class: X.Org Video Driver
        ABI class: X.Org Video Driver, version 23.0
(II) LoadModule: "fbdev"
(II) Loading /usr/lib/xorg/modules/drivers/fbdev_drv.so
(II) Module fbdev: vendor="X.Org Foundation"
        compiled for 1.19.3, module version = 0.4.4
        Module class: X.Org Video Driver
        ABI class: X.Org Video Driver, version 23.0
(II) LoadModule: "vesa"
(II) Loading /usr/lib/xorg/modules/drivers/vesa_drv.so
(II) Module vesa: vendor="X.Org Foundation"
        compiled for 1.19.3, module version = 2.3.4
        Module class: X.Org Video Driver
        ABI class: X.Org Video Driver, version 23.0
(II) NVIDIA dlloader X Driver  384.90  Tue Sep 19 16:35:54 PDT 2017
(II) NVIDIA Unified Driver for all Supported NVIDIA GPUs
(II) NOUVEAU driver Date:   Fri Apr 21 14:41:17 2017 -0400
(II) NOUVEAU driver for NVIDIA chipset families :
        RIVA TNT        (NV04)
        RIVA TNT2       (NV05)
        GeForce 256     (NV10)
        GeForce 2       (NV11, NV15)
        GeForce 4MX     (NV17, NV18)
        GeForce 3       (NV20)
        GeForce 4Ti     (NV25, NV28)
        GeForce FX      (NV3x)
        GeForce 6       (NV4x)
        GeForce 7       (G7x)
        GeForce 8       (G8x)
        GeForce GTX 200 (NVA0)
        GeForce GTX 400 (NVC0)
(II) modesetting: Driver for Modesetting Kernel Drivers: kms
(II) FBDEV: driver for framebuffer: fbdev
(II) VESA: driver for VESA chipsets: vesa
(II) Loading sub module "fb"
(II) LoadModule: "fb"
(II) Loading /usr/lib/xorg/modules/libfb.so
(II) Module fb: vendor="X.Org Foundation"
        compiled for 1.19.5, module version = 1.0.0
        ABI class: X.Org ANSI C Emulation, version 0.4
(II) Loading sub module "wfb"
(II) LoadModule: "wfb"
(II) Loading /usr/lib/xorg/modules/libwfb.so
(II) Module wfb: vendor="X.Org Foundation"
        compiled for 1.19.5, module version = 1.0.0
        ABI class: X.Org ANSI C Emulation, version 0.4
(II) Loading sub module "ramdac"
(II) LoadModule: "ramdac"
(II) Module "ramdac" already built-in
nvidia: Unknown symbol mcount (err 0)
nvidia: Unknown symbol mcount (err 0)
(EE) NVIDIA: Failed to initialize the NVIDIA kernel module. Please see the
(EE) NVIDIA:     system's kernel log for additional error messages and
(EE) NVIDIA:     consult the NVIDIA README for details.
(EE) [drm] Failed to open DRM device for pci:0000:01:00.0: -19
(EE) open /dev/dri/card0: No such file or directory
(WW) Falling back to old probe method for modesetting
(EE) open /dev/dri/card0: No such file or directory
(II) Loading sub module "fbdevhw"
(II) LoadModule: "fbdevhw"
(II) Loading /usr/lib/xorg/modules/libfbdevhw.so
(II) Module fbdevhw: vendor="X.Org Foundation"
        compiled for 1.19.5, module version = 0.0.2
        ABI class: X.Org Video Driver, version 23.0
(**) FBDEV(1): claimed PCI slot 1@0:0:0
(II) FBDEV(1): using default device
(WW) Falling back to old probe method for vesa
(EE) Screen 0 deleted because of no matching config section.
(II) UnloadModule: "modesetting"
(II) FBDEV(0): Creating default Display subsection in Screen section
        "Default Screen Section" for depth/fbbpp 24/32
(==) FBDEV(0): Depth 24, (==) framebuffer bpp 32
(==) FBDEV(0): RGB weight 888
(==) FBDEV(0): Default visual is TrueColor
(==) FBDEV(0): Using gamma correction (1.0, 1.0, 1.0)
(II) FBDEV(0): hardware: EFI VGA (video memory: 3072kB)
(II) FBDEV(0): checking modes against framebuffer device...
(II) FBDEV(0): checking modes against monitor...
(--) FBDEV(0): Virtual size is 1024x768 (pitch 1024)
(**) FBDEV(0):  Built-in mode "current": 78.7 MHz, 59.9 kHz, 75.7 Hz
(II) FBDEV(0): Modeline "current"x0.0   78.65  1024 1056 1184 1312  768 772 776 792 -hsync -vsync -csync (59.9 kHz b)
(==) FBDEV(0): DPI set to (96, 96)
(II) Loading sub module "fb"
(II) LoadModule: "fb"
(II) Loading /usr/lib/xorg/modules/libfb.so
(II) Module fb: vendor="X.Org Foundation"
        compiled for 1.19.5, module version = 1.0.0
        ABI class: X.Org ANSI C Emulation, version 0.4
(**) FBDEV(0): using shadow framebuffer
(II) Loading sub module "shadow"
(II) LoadModule: "shadow"
(II) Loading /usr/lib/xorg/modules/libshadow.so
(II) Module shadow: vendor="X.Org Foundation"
        compiled for 1.19.5, module version = 1.1.0
        ABI class: X.Org ANSI C Emulation, version 0.4
(II) UnloadModule: "vesa"
(II) Unloading vesa
(==) Depth 24 pixmap format is 32 bpp
(II) FBDEV(0): FBIOBLANK: Invalid argument (Screen blanking not supported by kernel - disabling)
(==) FBDEV(0): Backing store enabled
(==) FBDEV(0): DPMS enabled
(==) RandR enabled
(II) SELinux: Disabled on system
(EE) Failed to initialize GLX extension (Compatible NVIDIA X driver not found)
snd_hda_codec_ca0132 hdaudioC2D1: ca0132 DSP downloaded and running

I don't understand the messages related to the noveau driver since it is restricted.

dmesg yields:

[    1.279020] nvidia: loading out-of-tree module taints kernel.
[    1.279024] nvidia: module license 'NVIDIA' taints kernel.
[    1.279024] Disabling lock debugging due to kernel taint
[    1.282601] nvidia: module verification failed: signature and/or required key missing - tainting kernel
[    1.282771] nvidia: Unknown symbol mcount (err 0)
[    1.352268] nvidia: Unknown symbol mcount (err 0)
[    3.301475] nvidia: Unknown symbol mcount (err 0)
[    3.363942] nvidia: Unknown symbol mcount (err 0)
[    5.009364] nvidia: Unknown symbol mcount (err 0)
[    5.035475] nvidia: Unknown symbol mcount (err 0)
[   11.100897] nvidia: Unknown symbol mcount (err 0)
[   11.166281] nvidia: Unknown symbol mcount (err 0)
[   17.195212] nvidia: Unknown symbol mcount (err 0)
[   17.234473] nvidia: Unknown symbol mcount (err 0)
[   23.235776] nvidia: Unknown symbol mcount (err 0)
[   23.284352] nvidia: Unknown symbol mcount (err 0)
[   29.288938] nvidia: Unknown symbol mcount (err 0)
[   29.333988] nvidia: Unknown symbol mcount (err 0)
[   35.333656] nvidia: Unknown symbol mcount (err 0)
[   35.369983] nvidia: Unknown symbol mcount (err 0)
[   41.349484] nvidia: Unknown symbol mcount (err 0)
[   41.399202] nvidia: Unknown symbol mcount (err 0)
[   47.400332] nvidia: Unknown symbol mcount (err 0)
[   47.447558] nvidia: Unknown symbol mcount (err 0)
[   53.461137] nvidia: Unknown symbol mcount (err 0)
[   53.497349] nvidia: Unknown symbol mcount (err 0)
[   59.512240] nvidia: Unknown symbol mcount (err 0)
[   59.562157] nvidia: Unknown symbol mcount (err 0)
[   65.555357] nvidia: Unknown symbol mcount (err 0)
[   65.589552] nvidia: Unknown symbol mcount (err 0)
[   71.588204] nvidia: Unknown symbol mcount (err 0)
[   71.639669] nvidia: Unknown symbol mcount (err 0)

That last message repeats another hundred times at least.

Removing completely the driver let's me use the computer again.

1

After looking at this thread I realized that I had changed the default compiler cc from gcc to clang (same for c++ from g++ to clang++). So the fix:

  1. Revert the default compiler to gcc.
  2. Run apt clean to clean up the apt cache.
  3. Reinstall the nvidia drivers.
  • Same here. That was a difficult error to spot. I had to reconfigure gcc as well, since update-alternatives completely failed to find it for some reason. – Matjaz May 3 '18 at 8:47

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.