1

Newly installed Ubuntu 17.10.

Monitor: 2560x1080 60hz resolution with HDMI cable.

At boot loading I had some weird glitches as described in this question .

I disabled wayland in boot loading screen using: WaylandEnable=false

The boot loading screen & the login screen have the wrong resolution.

image

After I log in the resolution changes to the correct one.

How can I change the resolution during the boot loading screen and the login screen?

I already tried to edit /etc/default/grub and add my resolution for GRUB_GFXMODE. But it has no effect. Also related to this, when I type vbeinfo in the grub command line it says command not found.

1

Combinding some answers and comments primarily from this question and most of the following answer is from artfulrobot's answer

1) Turn on

2) At the grub menu press c to get the grub command line

3) Type videoinfo
This lists all the modes - it is the <width>x<height> you need to make note of. Only modes listed here will work and may not include your desired resolution.

4) Optionally, there is a videotest command which you can use to test a given resolution, e.g. videotest 1280x1024. However, while this test worked for me, I could not then get back to the grub menu! So that's not quite as useful (unless anyone can explain how to escape the test.)

5) Run the normal command to return to the normal grub menu.

6) Boot up fully and in a terminal run sudo nano /etc/default/grub. So un-comment and set the following lines to your desired mode. You may also need to add nomodeset.

GRUB_GFXMODE=1280x1024
GRUB_GFXPAYLOAD="keep"
GRUB_CMDLINE_LINUX="nomodeset"

6) Run update-grub and reboot.

  • My native resolution is not present in the videoinfo list and it does not work when set in GRUB_GFXMODE. When I set nomodeset all other resolution are no longer available in the system settings. I ended up putting in a lower resolution for GRUB_GFXMODE, the resolution automatically adjusts to the native one, and set GRUB_GFXPAYLOAD="keep" – g_t_sync Nov 11 '17 at 20:08
  • Yes the resolutions listed by 'videoinfo' are the only ones supported by grub on a given set of hardware. – J. Starnes Nov 11 '17 at 20:12
  • This only works for the first 1-2 restarts then it reverts back to the previous behavior. If I run update-grub it fixes it temporarily until the next day. – g_t_sync Nov 12 '17 at 8:53

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.